Closed Bug 1688978 Opened 6 months ago Closed 6 months ago

Possibly make the input[type="number"] arrows accomodate the available vertical space, when zoomed in, with non-native theming

Categories

(Core :: Widget: Win32, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
87 Branch
Fission Milestone M7
Tracking Status
firefox87 --- fixed

People

(Reporter: itiel_yn8, Assigned: emilio)

References

Details

Attachments

(4 files)

Attached image 220% zoom in

In 100% (default) zoom, the arrows accomodate the available vertical space, but when zoomed in there's a blank space below and above the arrows. See attached.

Attached image Default zoom

This matches other browsers, and also common sense (I'd be ok letting
scrollbars grow or shrink too tbf, but...).

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Attachment #9199374 - Attachment description: Bug 1688978 - Make native theme widgets grow with zoom as usual, except for scrollbars. r=mstange,spohl → Bug 1688978 - Make non-native theme widgets grow with zoom as usual, except for scrollbars. r=mstange,spohl
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c8750c7f296
Make non-native theme widgets grow with zoom as usual, except for scrollbars. r=mstange

We might want to snap focus outline widths as well, but that's harder
because it has various segments and separation between them, so we
probably want to snap those separately... So for now only border rects
probably makes sense.

Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/ccacb0fa77d9
Add a missing argument in mac-only code. CLOSED TREE
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/17df09fc7b4c
Snap border widths in the non-native theme like we snap layout borders. r=mstange
Fission Milestone: --- → M7
Duplicate of this bug: 400364
You need to log in before you can comment on or make changes to this bug.