Closed Bug 1689045 Opened 9 months ago Closed 9 months ago

Broken UI in Message Header after bug 1686603

Categories

(Thunderbird :: Theme, defect)

Unspecified
All
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird86 unaffected)

RESOLVED FIXED
87 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird86 --- unaffected

People

(Reporter: aleca, Assigned: Paenglab)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

It seems that the Message Header is broken on trunk in macOS.
I didn't notice this issue on Linux, and I'm not sure if it's happening on Windows.

The addressing area doesn't grow as it's supposed to. Adding a flex: 1; CSS attribute to that container fixes it, but I'm not sure is the right fix and I'd be curious to know what broke it.

Must be something in the latest check-ins from m-c. I checked before, all ok and with latest I see this too.

Good catch, Alex!

This is a regression from bug 1686603.

OS: macOS → All
Regressed by: 1686603

Fixing it by adding the flex: 1;. I also removed the unneeded html|table selector part.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9199525 - Flags: review?(alessandro)
Comment on attachment 9199525 [details] [diff] [review]
1689045-expandedHeaders2-flex.patch

Review of attachment 9199525 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for fixing this!

::: mail/themes/shared/mail/messageHeader.css
@@ +285,5 @@
> +#expandedHeaders2 {
> +  flex: 1;
> +}
> +
> +#expandedHeaders,

Are you sure the #expandedHeaders doesn't need the flex as well?
Attachment #9199525 - Flags: review?(alessandro) → review+

(In reply to Alessandro Castellani (:aleca) from comment #5)

Are you sure the #expandedHeaders doesn't need the flex as well?

This doesn't work because his parent has no display: flex;. And probably not needed because the parent has display: block;.

Target Milestone: --- → 87 Branch
Summary: Broken UI in Message Header → Broken UI in Message Header after bug 1686603

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/f6354f32e562
Add a flex to expandedHeaders2 to expand it over the whole width. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

I don't think bug 1686603 was meant to have observable changes, really. TYLin, would you mind taking a look here and seeing if this fallout makes sense or was unexpected (& possibly indicative of there being a risk for potential breakage on the web, too)?

Flags: needinfo?(aethanyc)

Filed bug 1689719 to investigate the rendering difference of <table> as a flex item.

Flags: needinfo?(aethanyc)
You need to log in before you can comment on or make changes to this bug.