Closed Bug 168924 Opened 18 years ago Closed 4 years ago

AudioGraph plug-in doesn't work correctly

Categories

(Core :: Plug-ins, defect, P3)

PowerPC
macOS
defect

Tracking

()

RESOLVED WONTFIX
mozilla1.3beta

People

(Reporter: bossman, Assigned: peterl-bugs)

References

()

Details

(Whiteboard: [PL2:NA])

Chimera quits on all pages I have tried that contain an embed for the AudioGraph
plug-in. AudioGraph plug-in works with Mozilla 1.0 and 1.01. Our regression
tests for the plug-in are at:
http://www2.dcs.hull.ac.uk/people/csscrj/Regression_tests.f/Index.htm, each link
on this page contains an embedded audiograph file.
The plug-in can be downloaded from: http://www.nzedsoft.com/audiographplugin.html.
This occurs for both 0.5 release and latest build (202091504).
Chris, does it also happen using more recent Mozilla builds like 1.1 or 1.2a?
Please attach the crash report generated when Chimera crashed.
Severity: blocker → critical
Keywords: crash, stackwanted
Plugin does not crash under current builds. It does not appear to work correctly
though (under either Chimera or Mozilla (N7) on OS 10.2.1.)
Severity: critical → normal
No longer a crash... keyword cleanup.
Keywords: crash, stackwanted
Revising summary per comment 2.
Summary: Chimera 0.5 quits on pages containing AudioGraph plug-in → AudioGraph plug-in doesn't work correctly
Reporter and Brian: Does this still not work or crash?
Confirmed using Chimera/2002112604.
Status: UNCONFIRMED → NEW
Ever confirmed: true
First attempt to play regression test #1 using Chimera/2002112604 (see comment
6) resulted in nothing being drawn and no sound played by the plug-in.
Proceeding to test 6 still had no results, but switching to
FizzillaMach/2002112607, quitting FizzillaMach, and returning to Chimera showing
test 6 caused plug-in to draw. Returning to test 1 caused sound to play as well,
though the four widgets flanking the progress meter visible using IE aren't shown.

Also reproduced using FizzillaMach/2002112607; at first regression test, sound
played, but plug-in controls were incompletely drawn as mentioned above.

Reassigning to Browser/Plug-ins.
Assignee: bnesse → beppe
Product: Chimera → Browser
QA Contact: petersen → shrir
Version: unspecified → Trunk
assigning to Peter
Assignee: beppe → peterl
Priority: -- → P3
Whiteboard: [PL2:NA]
Target Milestone: --- → mozilla1.3beta
QA Contact: shrir → plugins
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.