Closed Bug 1689405 Opened 5 months ago Closed 5 months ago

Do initial simplification of the Library menu

Categories

(Firefox :: Menus, task)

task

Tracking

()

RESOLVED FIXED
87 Branch
user-doc-firefox docs-needed
Tracking Status
relnote-firefox --- 87+
firefox87 --- fixed

People

(Reporter: mconley, Assigned: emalysz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-hamburger-menu])

Attachments

(1 file)

This is something that can ship pre-Proton, so it can happen immediately, and doesn't need to be behind a pref.

This is mainly removal, so should be reasonably straight-forward (he said, tempting fate).

For now, Library should be as follows:

Bookmarks >
View Pocket List
History >
Downloads

What we need to do:

  1. Remove the "Synced Tabs" and "Recent Highlights" sections.
  2. Have the "Downloads" button open up the Downloads section in the Library window. That can be done by using the DownloadsPanel.showDownloadsHistory(); function, like this. This also means removing the "subviewbutton-nav" class from the item to get rid of the ">".
  3. With the Downloads subview no longer accessible, we can fully remove it. That means getting rid of DownloadsSubview.jsm, this chunk of markup, and any tests that exercise the Downloads subview. Also a good opportunity to cull any strings that aren't being used anymore with that subview gone.

Naturally, any tests that rely on the old structure or old behaviours will need to be modified as well.

Late breaking additional change - we're okay to remove View Pocket List as well. This means removing this entry, the pocketMenuitem.label DTD, and any styles or tests involving appMenu-library-pocket-button: https://searchfox.org/mozilla-central/search?q=appMenu-library-pocket-button&path=&case=false&regexp=false

Assignee: nobody → emalysz
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/164e8109e012
remove components of library panel r=mconley
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

Release Note Request (optional, but appreciated)
[Why is this notable]:

We're changing the composition of one of our default toolbar item menus.

[Affects Firefox for Android]:

No.

[Suggested wording]:

We've removed some items from the Library button that weren't used often, or have other access points in the browser.

[Links (documentation, blog post, etc)]:

None.

relnote-firefox: --- → ?

Setting docs-needed since we're removing the following items from the Library menu:

  • Synced Tabs (these can be accessed via the Firefox Accounts submenu
  • Recent highlights
  • View Pocket List (users can go to https://getpocket.com/my-list to view their list)
Regressions: 1694446

Added to the 87.0beta release notes

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #6)

Setting docs-needed since we're removing the following items from the Library menu:
<snip>

I updated https://support.mozilla.org/en-US/kb/save-web-pages-later-pocket-firefox for fx87

Regressions: 1704337

Hi,
Why did you remove the "view pocket list" from the library menu? This is a regression...!
We have a button to save the pages but none to go in his list!
Why was it on this menu? If you really wanted to remove it, you should have first added a feature in the "pocket" button to access its list.
Now, we have to lose 5 minutes to find the link to your pocket list even if you can add a bookmark afterward.

In short, it was better before. Please put back this "view pocket list" button in the library menu in the next version of FF ;-)

No longer regressions: 1704337
See Also: → 1704337
You need to log in before you can comment on or make changes to this bug.