Closed Bug 1689477 Opened 6 months ago Closed 6 months ago

Consider removing the padding special-case for <input type=number>

Categories

(Core :: Widget, task, P3)

task

Tracking

()

RESOLVED FIXED
87 Branch
Fission Milestone M7
Tracking Status
firefox87 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(1 file)

As noted in bug 1689231, <input type=number> and regular <input> sizing differs with this, which seems unfortunate.

This means that the number input by default shows some white space to
the right of the spinners. I think it's probably not the end of the
world, and depending on the different trade-offs we might want to do
this instead of fixing the test.

Depends on D103270

Severity: -- → N/A
Fission Milestone: --- → M7
Priority: -- → P3
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d94527834d1d
Remove number-input padding special-case so that we size them the same way as text controls. r=spohl
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
Duplicate of this bug: 1687178
You need to log in before you can comment on or make changes to this bug.