Closed Bug 1689615 Opened 6 months ago Closed 6 months ago

Reddit comment box has a triple outline with non-native theme

Categories

(Core :: Widget, defect)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
87 Branch
Fission Milestone M7
Tracking Status
firefox87 --- fixed

People

(Reporter: evilpie, Assigned: emilio)

References

Details

(Whiteboard: fission-nnt)

Attachments

(4 files)

Attached image textarea.png

On old.reddit.com there are now three outlines when commenting. One inner red, and two shades of blue. The inner red is from reddit or maybe RES.

Summary: Reddit comment box has a trible outline with non-native themeing → Reddit comment box has a triple outline with non-native themeing
Attached file test-case

So this is about our focus outline-style: auto being quite large, basically... Maybe we shouldn't paint the extra outline for outline-style: auto. And maybe outline-style: auto should follow border-radius like it does on Safari. With that I think this would look fine, not sure.... thoughts?

Summary: Reddit comment box has a triple outline with non-native themeing → Reddit comment box has a triple outline with non-native theme
Fission Milestone: --- → M8
Blocks: 1690140

Tracking for Fission M7 Beta. I can't reproduce on Windows.

Fission Milestone: M8 → M7
OS: Unspecified → Linux
Whiteboard: fission-nnt
Attached image Google_Doc_comment.png

I also see a triple-border when adding Google Doc comments.

Flags: needinfo?(emilio)

I don't see that in google docs Chris, does it repro in a clean profile?

Flags: needinfo?(emilio) → needinfo?(cpeterson)

outline-style: auto might show up in non-themed controls and such, and
the double-outline there might look ugly.

Following border-radius would be an extra improvement for the reddit
case, but no platform does it currently (Safari on macOS does it), so
let's consider that in a follow-up.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Duplicate of this bug: 1690140
Blocks: 1691064
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/641f63f2a006
Only paint one outline for outline-style:auto with nnt. r=mstange

(In reply to Chris Peterson [:cpeterson] from comment #4)

I also see a triple-border when adding Google Doc comments.

(In reply to Emilio Cobos Álvarez (:emilio) from comment #5)

I don't see that in google docs Chris, does it repro in a clean profile?

Odd. I can no longer reproduce the Google Docs issue in my regular profile or a clean profile.

Flags: needinfo?(cpeterson)
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
You need to log in before you can comment on or make changes to this bug.