Closed Bug 1689632 Opened 8 months ago Closed 8 months ago

Simplify Help menu

Categories

(Firefox :: Menus, task, P1)

task

Tracking

()

VERIFIED FIXED
87 Branch
user-doc-firefox docs-needed
Tracking Status
relnote-firefox --- 87+
firefox87 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-hamburger-menu])

Attachments

(1 file)

This is something that can ship pre-Proton, so it can happen directly on the Help menu here: https://searchfox.org/mozilla-central/rev/f9ad45c76ba50bdee54bebd14e6625ae14d4d085/browser/base/content/browser-menubar.inc#456-534

The menu structure should be like this:

{ brand shorter name } Help <header>
<separator>
Get Help
Submit Feedback...
Troubleshooting Information
Report Deceptive Site...
About { brand shorter name } <Windows and Linux only>

(Task Manager is going to go in there too somewhere, but I don't know where yet.)

Things to do:

  1. We need a new string for the header. PanelMultiView.jsm looks at the <panelview> node to see if there's a title attribute, and if it can't find one, it'll set the header to be whatever the anchor text was (in this case, "Help" from the Help toolbarbutton in the AppMenu). What we need to do is add a new string to appmenu.ftl, like this:
appmenu-help-header =
    .title = { -brand-shorter-name } Help

Then, on the panelview node for the Help subview, set data-l10n-id="appmenu-help-header" and data-l10n-attrs="title".

  1. The Help subview constructs itself dynamically based on what's in the Help menubar menu. That's done here. So what we need to do here is edit the menubar Help menu, and that'll be reflected in the AppMenu Help subview. So remove and re-arrange the items in there based on what's in the description above. There are some default-hidden "policy" items here that you can keep above the "About" item for now - I'll chase down the expected placement for those later.

  2. Get rid of any strings for items that we're discarding, where we're not using those strings elsewhere. Don't forget to also get rid of the appmenu string variants for the ones you're removing too.

  3. Any new strings that need to be added need to have new IDs, and need to have AppMenu variants. See this comment.

  4. Remove this weird ifdef while you're in the neighbourhood, because it looks vestigial.

Naturally, there might be one or more tests that will need to be updated due to these changes. Make sure to push to try to try to find those.

Gonna nab this myself and try to drive it through.

Assignee: nobody → mconley

Mike, was looking through the backlog on help menu enhancements and I found a few bugs proposing the addition of a "Reset Firefox..." (refresh Firefox) menu item here. See bugs 872241, 915908.

Does it make sense to include this in this change?

Severity: -- → N/A
Priority: -- → P1
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/53803267e618
Simplify the Help menu a bit. r=emalysz,fluent-reviewers,flod

(In reply to Asif Youssuff from comment #3)

Does it make sense to include this in this change?

There's a concerted effort to reduce the number of redundant items in our primary menus. I'd bucket "Refresh Firefox" in the same category as entering Safe Mode: this is a troubleshooting / diagnosis tool, for which there's pre-existing access in about:support. So I imagine we should just close those old bugs as WONTFIX.

Release Note Request (optional, but appreciated)
[Why is this notable]:

Our primary Help menu is changing its composition / ordering.

[Affects Firefox for Android]:

No.

[Suggested wording]:

We've simplified the Help menu by reducing some redundant items, or items that point to support pages that can also be accessed via the Get Help item.

[Links (documentation, blog post, etc)]:

None.

relnote-firefox: --- → ?

Setting docs-needed in case there are pre-existing documents in our support pages that refer to the old structure of the Help menu that will need to be updated.

To be clear, the items that were removed from the Help menu were:

  • Firefox Tour
  • Import from Another Browser
  • Keyboard Shortcuts
  • Restart with Add-ons Disabled
Duplicate of this bug: 915908
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

Per Romain, removing items from the menu bar wasn't in scope— we were only to change labels for existing items to align with decisions in the hamburger menu. See slide 49 in the menu deck.

Is it the case that we have to update the menu bar because the menu bar pulls its contents direction from the hamburger menu?

Flags: needinfo?(mconley)

(In reply to Meridel from comment #10)

Is it the case that we have to update the menu bar because the menu bar pulls its contents direction from the hamburger menu?

Yes, that's the case. I had assumed we'd want to maintain the consistency between both Help menus (with the exception of the casing of the strings). Do we need to put some menubar Help menu items back?

Flags: needinfo?(mconley) → needinfo?(mwalkington)

Ok, got it. I synced with Romain and he did not see an issue with being consistent for the Help menus— if anything, this is an unexpected bonus.

Flags: needinfo?(mwalkington)

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #7)

To be clear, the items that were removed from the Help menu were:
<snip>

  • Restart with Add-ons Disabled

See bug 1690858 comment 18 on adding back "Restart with Add-ons Disabled" to the Help menu.

Added to the 87.0beta release notes.

Verified - Fixed in Release 88, Beta 89.0b12 and latest Nightly 90.0a1 (2021-05-17) using Windows 10, macOS 11 and Ubuntu 20.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.