bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Help: Adding another field for Index sorting



Help Documentation
16 years ago
7 years ago


(Reporter: rchen, Unassigned)



Dependency tree / graph

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [adt3][browser])



16 years ago
The initial proposal is to add additional field in help-index1.rdf.  For example,

<rdf:Description about="help-indexAZ.rdf#a">
       <rdf:Description ID="Account_Settings"
         nc:name="Account Settings"

We can add nc:sortkey="" after nc:name.

       <rdf:Description ID="Account_Settings"
         nc:name="Account Settings"

We may add one flag to indicate that the sortkey is used for sorting in the dtd
<!ENTITY usesortkey "false">

For Japanese or Chinese, we will have pronunciation data in the field and set 
<!ENTITY usesortkey "true">

When usesortkey is true, we should sort nc:sortkey, not nc:name.

The sortflag is still necessary in case we need to turn off sorting. 
<!ENTITY sortflag           "true">

If sortflag is true, there is no sorting in the program.


16 years ago
OS: Windows 2000 → All
Summary: Adding another field for Index sorting → Help: Adding another field for Index sorting

Comment 1

16 years ago
ACCEPTING. I think we can have this in for the next release.

Comment 2

16 years ago
Thanks Ian. I am a bit worried that this might add additional localization costs
to the project. Could you please give us some info on what additional costs we
might incur due to this fix? We're on a tight l10n budget for the next release.
Actually if it will add costs then we might not want it for the next release... 
cc. Robin


16 years ago
Blocks: 157673

Comment 3

16 years ago
adding nsbeta1+
Keywords: nsbeta1+


16 years ago
Whiteboard: [browser]

Comment 4

15 years ago
i18n triage team: nsbeta1+/adt3
Whiteboard: [browser] → [adt3][browser]

Comment 5

15 years ago
moving stuff over to an outside-the-firewall email for the time being, looking
for people to pick these Help and doc bugs up for me.
Assignee: oeschger → oeschger

Comment 6

15 years ago
mass reassign of all of Ian Oeschger's bugs to me (R.J. Keller).
Assignee: oeschger → rlk

Comment 7

15 years ago
--> Brant, the RDF guy.

Brant, could we get this for Firebird Help (don't resolve when fixed)?
Assignee: rlk → brantgurganus2001

Comment 8

15 years ago
I'm not sure how to implement this at the moment.  I'm still trying to get
toolbar customization to work.


15 years ago
QA Contact: tpreston → stolenclover

Comment 9

15 years ago
This looks like moving a problem instead of fixing it.

When i translated the file into Dutch i notice this behaviour:
1) Only part of what starts with 'about="help-indexAZ.rdf#*"' is inserted.
2) Everything else is sorted correctly.

I'd expect the following:

for every line containing 'about="help-indexAZ.rdf#*"':
    key = *
    if !key in keys
        keys.insert(key) # keep the list sorted

Another benefit of inserting/sorting the 'about="help-indexAZ.rdf#*"' items this
way is that it will also prevent characters that are not used filling up the
list, for as it is at the moment  every character in the alphabet is shown
regardles of it's contents.

Not that i know any Chinese or Japanese, but i'd expect you'll have to translate
the help-indexAZ.rdf to create the list of sortkeys to use in help-index1.rdf.



Comment 10

15 years ago
moving owners around.
Assignee: brantgurganus2001 → rlk
Keywords: helpwanted

Comment 11

14 years ago
Moving to new Help component owner.
Assignee: rlk → neil.parkwaycc.co.uk
Product: Browser → Seamonkey

Comment 12

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

8 years ago
I hope this will get covered off when bug 130733 gets fixed, so marking dependency.
Assignee: neil → nobody
Depends on: 130733
Ever confirmed: true
QA Contact: danielwang → help
Hardware: x86 → All

Comment 14

7 years ago
bug 130733 is WONTFIX (Index doesn't exist any more) so this bug is INVALID/WONTFIX
Last Resolved: 7 years ago
Resolution: --- → FIXED
Resolution: FIXED → WONTFIX
You need to log in before you can comment on or make changes to this bug.