Closed Bug 1691285 Opened 3 years ago Closed 3 years ago

tag and 'mailing lists' list in global search has scrollbar because 'None' label is missing

Categories

(Thunderbird :: Search, defect)

defect

Tracking

(thunderbird_esr78 unaffected, thunderbird85 affected, thunderbird86 affected, thunderbird87 affected)

RESOLVED FIXED
87 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird85 --- affected
thunderbird86 --- affected
thunderbird87 --- affected

People

(Reporter: aryx, Assigned: aria)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

The tag list in the global search sidebar has a scrollbar because the 'None' label is missing.

Steps to reproduce:

  1. Tag several message: Select message, press a number 1-5 (forces the tag selector in the global search to be shown).
  2. Click "Get Messages" button at top left (rebuilds search database with the tags).
  3. In the global search bar, search e.g. for the host of your email.

Actual result:
Tag list in sidebar of search results has scrollbar because 'None' tag for messages without tags is missing.

Expected result:
'None' tag shown + no scroll bar.

This is from bug 1637136. ariasuni, do you want to investigate?

Flags: needinfo?(perso)
Summary: tag list in global search has scrollbar because 'None' label is missing → tag and 'mailing lists' list in global search has scrollbar because 'None' label is missing
Assignee: nobody → perso
Status: NEW → ASSIGNED

The problem seems kind of obvious now that I review my code from 5 months ago. The patch worked at the time because there wasn’t the new translations yet, but now the bug appears. I made a patch and tested that it fixes the problem.

Flags: needinfo?(perso)
Target Milestone: --- → 87 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/caf1d9b64a90
fix some labels having no text in global search. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: