Closed Bug 1691513 Opened 1 year ago Closed 1 year ago

Simplify MimeTypeArray, PluginArray, MimeType, and Plugin

Categories

(Core Graveyard :: Plug-ins, task)

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1682030

People

(Reporter: d, Unassigned)

References

Details

We recently updated the HTML spec to match Firefox's behavior and have navigator.plugins and navigator.mimeTypes always be empty: https://github.com/whatwg/html/pull/6296

Since MimeTypeArray and PluginArray are always empty, you can dramatically simplify their IDL and backing C++ code. I thought you might appreciate a tracking bug for such cleanup work.

We may in the future remove MimeType and Plugin entirely: https://github.com/whatwg/html/issues/6317 . (The spec does not yet do that though.)

See Also: → 1687845

We do remove MimeType and Plugin in Bug 1682030 (a big NPAPI removal refactor, not yet landed) but we leave MimeTypeArray and PluginArray. The reason is that the array types are visible to JS so we keep them, even though there are no plugins (or adjacent mime-types) that we support so those arrays are always empty. Their contents -- MimeType and Plugin -- can't exist so we don't need them. The array classes are hard-coded to contain no elements.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1682030
See Also: 1687845
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.