Closed Bug 1682030 Opened 5 months ago Closed 1 month ago

Mass removal of NPAPI plugin code

Categories

(Core :: Plug-ins, task, P1)

task

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: handyman, Assigned: handyman)

References

(Blocks 1 open bug)

Details

Attachments

(25 files, 43 obsolete files)

48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review

Bug for the initial omnibus NPAPI-plugin-removal patch series. We will work to include nearly all of the NPAPI-exclusive code across the repo, and to refactor some components around its integration, but may leave some stragglers. Bug 1677160 is the umbrella bug for all NPAPI removal.

Blocks: 1685183
Blocks: 1685181
Duplicate of this bug: 1688667

David, are you still working on this?

Flags: needinfo?(davidp99)
Blocks: 1689348

(In reply to Mats Palmgren (:mats) from comment #45)

David, are you still working on this?

Yes, still active. It should be wrapping up now. Try again in a week or so.

Flags: needinfo?(davidp99)

OK, good to know. FYI, we removed most of the layout/ code in bug 1687239, so you might get a few conflicts from that (sorry, I wasn't aware of this work at the time).

Gentle ping. Even just dropping the tests (D99508) would help us drop depends on gtk2 (1377445).

Attachment #9192701 - Attachment is obsolete: true
Attachment #9192704 - Attachment is obsolete: true
Attachment #9192705 - Attachment is obsolete: true
Attachment #9192706 - Attachment is obsolete: true
Attachment #9192707 - Attachment is obsolete: true
Attachment #9192708 - Attachment is obsolete: true
Attachment #9192709 - Attachment is obsolete: true
Attachment #9192710 - Attachment is obsolete: true
Attachment #9192711 - Attachment is obsolete: true
Attachment #9192712 - Attachment is obsolete: true
Attachment #9192713 - Attachment is obsolete: true
Attachment #9192714 - Attachment is obsolete: true
Attachment #9192715 - Attachment is obsolete: true
Attachment #9192716 - Attachment is obsolete: true
Attachment #9192717 - Attachment is obsolete: true
Attachment #9192718 - Attachment is obsolete: true
Attachment #9192719 - Attachment is obsolete: true
Attachment #9192720 - Attachment is obsolete: true
Attachment #9192721 - Attachment is obsolete: true
Attachment #9192722 - Attachment is obsolete: true
Attachment #9192723 - Attachment is obsolete: true
Attachment #9192724 - Attachment is obsolete: true
Attachment #9192725 - Attachment is obsolete: true
Attachment #9192726 - Attachment is obsolete: true
Attachment #9192727 - Attachment is obsolete: true
Attachment #9192728 - Attachment is obsolete: true
Attachment #9192729 - Attachment is obsolete: true
Attachment #9192730 - Attachment is obsolete: true
Attachment #9192731 - Attachment is obsolete: true
Attachment #9192732 - Attachment is obsolete: true
Attachment #9192733 - Attachment is obsolete: true
Attachment #9192734 - Attachment is obsolete: true
Attachment #9192735 - Attachment is obsolete: true
Attachment #9192736 - Attachment is obsolete: true
Attachment #9192737 - Attachment is obsolete: true
Attachment #9192738 - Attachment is obsolete: true
Attachment #9192739 - Attachment is obsolete: true
Attachment #9192740 - Attachment is obsolete: true
Attachment #9192741 - Attachment is obsolete: true
Attachment #9192742 - Attachment is obsolete: true
Attachment #9192743 - Attachment is obsolete: true
Attachment #9192744 - Attachment is obsolete: true
Attachment #9192745 - Attachment is obsolete: true

Removes NPAPI plugin features from tests outside of dom/plugins. Some tests are updated to avoid NPAPI behavior and others are deleted if they no longer offer anthing useful.

Removes NPAPI plugin tests in dom/plugins, as well as the TestPlugin, as part of removing all of NPAPI plugin support. A small handful of tests that are still relevant remain in that directory.

Depends on D107134

Removes the PPluginSurface actor used for windowed plugins, as part of removing all of NPAPI plugin support. SharedDIB is then unused and is also removed.

Depends on D107138

Removes the NPAPI plugin widget actor and its proxy, as part of removing all of NPAPI plugin support.

Depends on D107140

Removes the mac plugin_interposer (and the related NSCursorInfo behavior), as part of removing all of NPAPI plugin support, since it has no other clients.

Depends on D107141

Removes NPAPI plugin support from accessible/, as part of removing all of NPAPI plugin support. This was the only reason for HTMLWin32ObjectAccessible was needed, so we get rid of that, too.

Depends on D107142

This is the first of two patches in this series that removes a large amount of now dead code from dom/plugins as part of removing all NPAPI plugin support. This patch removes re-entrancy guards we have for Windows OnPaint messages, as the guards were only needed for windowed plugins.

Depends on D107143

Removes nsIPluginDocument and its implementation as part of removing all NPAPI plugin support.

Depends on D107144

Removes NPAPI plugin support from the ClearDataService as part of removing all of NPAPI.

Depends on D107145

Removes Flash version and plugin blocklist data from telemetry and about:telemetry as part of removing all NPAPI plugin support.

Depends on D107146

Removes the PluginProvider and NPAPI plugin blocklist handling as part of removing all NPAPI support. This allows us to remove nsIPluginHost.

Depends on D107147

Removes unused nsIPluginWidget, as part of removing all NPAPI support.

Depends on D107148

This is the second of two patches in this series that removes a large amount of now dead code from dom/plugins as part of removing all NPAPI plugin support.

Depends on D107149

We still use these types so that the typing of these arrays in navigator follows the spec but they are never populated since we have removed all NPAPI plugin support. So these classes are greatly simplified.

Depends on D107150

Removes async (windowless) NPAPI plugin rendering methods used to render a plugin to an offscreen surface in the GPU process. None of this code is used since we have removed all NPAPI plugin support.

Depends on D107151

Removes stale windowed NPAPI plugin layers support as part of removing all NPAPI support.

Depends on D107152

As part of removing all NPAPI plugin support, CTP is no longer relevant (it does not apply to GMP plugins) so we remove the option from about:addons.

Depends on D107153

Removes the methods for handling NPAPI plugin process crashes, as we are eliminating all NPAPI behavior.

Depends on D107154

As part of removing all NPAPI plugin support, plugin MIME type is no longer relevant (it does not apply to GMP plugins) so we remove the table from about:plugins.

Depends on D107155

Removes NPAPI support from JS plugin actors, most of which was CTP-and-fallback overlay related, leaving them to only do GMP crash handling.

Depends on D107156

Similifies use of EventStates and ObjectType/FallbackType enums since most states they represented are no longer valid with the removal of NPAPI plugins. The state machine for (unsupported) plugin elements is now much simpler but still distinguishes between HTML fallbacks, fallbacks leading to a "BROKEN" state (e.g. failing to load the image the element refers to), and fallbacks that would simply lead the element to occupy an empty region. The last type of fallback is behind a pref "layout.use-plugin-fallback" and is disabled by default.

Simplifying the state machine allows us to clean up nsObjectLoadingContent. We also update many of the enums which refered to plugins, which would otherwise get confusing.

Depends on D107157

HiddenPluginEvent is no longer used since NPAPI plugin support has been removed.

Depends on D107158

Duplicate of this bug: 1677877
Duplicate of this bug: 1677878
Duplicate of this bug: 1575726
Duplicate of this bug: 1296400
Duplicate of this bug: 1677137
Duplicate of this bug: 1678110
Duplicate of this bug: 1685181
Duplicate of this bug: 1688637
Duplicate of this bug: 1691513
Duplicate of this bug: 1687845
Duplicate of this bug: 1489496
Attachment #9206780 - Attachment description: Bug 1682030 - Remove NPAPI from tests outside of dom/plugins. DONTBUILD r=jmathies!,gijs! → Bug 1682030 - Remove NPAPI from tests outside of dom/plugins. r=jmathies!,gijs!
Attachment #9206784 - Attachment description: Bug 1682030 - Remove NPAPI from dom/plugins tests. DONTBUILD r=jmathies! → Bug 1682030 - Remove NPAPI from dom/plugins tests. r=jmathies!
Attachment #9206786 - Attachment description: Bug 1682030 - Remove PPluginSurface. DONTBUILD r=jmathies!,bas! → Bug 1682030 - Remove PPluginSurface. r=jmathies!,bas!
Attachment #9206787 - Attachment description: Bug 1682030 - Remove PPluginWidget. DONTBUILD r=jmathies! → Bug 1682030 - Remove PPluginWidget. r=jmathies!
Attachment #9206788 - Attachment description: Bug 1682030 - Remove OSX interposer. DONTBUILD r=haik! → Bug 1682030 - Remove OSX interposer. r=haik!
Attachment #9206789 - Attachment description: Bug 1682030 - Remove NPAPI plugin support from accessible. DONTBUILD r=marcoz! → Bug 1682030 - Remove NPAPI plugin support from accessible. r=marcoz!
Attachment #9206790 - Attachment description: Bug 1682030 - Remove some dead NPAPI code from dom/plugins and related spots. DONTBUILD r=jmathies!,jld!,mconley! → Bug 1682030 - Remove some dead NPAPI code from dom/plugins and related spots. r=jmathies!,jld!,mconley!
Attachment #9206791 - Attachment description: Bug 1682030 - Remove nsIPluginDocument. DONTBUILD r=jmathies!,emilio! → Bug 1682030 - Remove nsIPluginDocument. r=jmathies!,emilio!
Attachment #9206792 - Attachment description: Bug 1682030 - Remove NPAPI support from ClearDataService. DONTBUILD r=baku! → Bug 1682030 - Remove NPAPI support from ClearDataService. r=baku!
Attachment #9206793 - Attachment description: Bug 1682030 - Remove NPAPI plugins from telemetry DONTBUILD r=gijs! → Bug 1682030 - Remove NPAPI plugins from telemetry r=gijs!
Attachment #9206794 - Attachment description: Bug 1682030 - Remove NPAPI blocklisting DONTBUILD r=gijs!,jmathies! → Bug 1682030 - Remove NPAPI blocklisting r=gijs!,jmathies!
Attachment #9206795 - Attachment description: Bug 1682030 - Remove nsIPluginWidget DONTBUILD r=jmathies! → Bug 1682030 - Remove nsIPluginWidget r=jmathies!
Attachment #9206796 - Attachment description: Bug 1682030 - Remove more dead NPAPI code from dom/plugins and related spots. DONTBUILD r=jmathies!,mconley!,emilio! → Bug 1682030 - Remove more dead NPAPI code from dom/plugins and related spots. r=jmathies!,mconley!,emilio!
Attachment #9206797 - Attachment description: Bug 1682030 - Reduce nsMimeTypeArray and nsPluginArray to "constants" DONTBUILD r=jmathies! → Bug 1682030 - Reduce nsMimeTypeArray and nsPluginArray to "constants" r=jmathies!
Attachment #9206798 - Attachment description: Bug 1682030 - Remove NPAPI plugin async rendering support DONTBUILD r=bas!,jld! → Bug 1682030 - Remove NPAPI plugin async rendering support r=bas!,jld!
Attachment #9206799 - Attachment description: Bug 1682030 - Remove NPAPI windowed plugin layer support DONTBUILD r=bas! → Bug 1682030 - Remove NPAPI windowed plugin layer support r=bas!
Attachment #9206800 - Attachment description: Bug 1682030 - Remove CTP option from about:addons DONTBUILD r=rpl! → Bug 1682030 - Remove CTP option from about:addons r=rpl!
Attachment #9206801 - Attachment description: Bug 1682030 - Remove NPAPI plugin reporting from crashreporter DONTBUILD r=mconley! → Bug 1682030 - Remove NPAPI plugin reporting from crashreporter r=mconley!
Attachment #9206802 - Attachment description: Bug 1682030 - Remove MIME type table from about:plugins DONTBUILD r=gijs! → Bug 1682030 - Remove MIME type table from about:plugins r=gijs!
Attachment #9206803 - Attachment description: Bug 1682030 - Remove NPAPI overlay from JS Plugin actors DONTBUILD r=gijs! → Bug 1682030 - Remove NPAPI overlay from JS Plugin actors r=gijs!
Attachment #9206804 - Attachment description: Bug 1682030 - Clean up NPAPI plugin fallback behavior. DONTBUILD r=gijs!,jmathies!,emilio! → Bug 1682030 - Clean up NPAPI plugin fallback behavior. r=gijs!,jmathies!,emilio!
Duplicate of this bug: 1505543

Removes the Flash sandbox descriptor as part of removing all NPAPI plugin support.

Attachment #9206780 - Attachment description: Bug 1682030 - Remove NPAPI from tests outside of dom/plugins. r=jmathies!,gijs! → Bug 1682030 - Remove NPAPI from tests outside of dom/plugins. r=jmathies!,gijs!,gsvelto!
Attachment #9206784 - Attachment description: Bug 1682030 - Remove NPAPI from dom/plugins tests. r=jmathies! → Bug 1682030 - Remove NPAPI from dom/plugins tests. r=jmathies!
Attachment #9206786 - Attachment description: Bug 1682030 - Remove PPluginSurface. r=jmathies!,bas! → Bug 1682030 - Remove PPluginSurface. r=jmathies!,bas!
Attachment #9206787 - Attachment description: Bug 1682030 - Remove PPluginWidget. r=jmathies! → Bug 1682030 - Remove PPluginWidget. r=jmathies!
Attachment #9206788 - Attachment description: Bug 1682030 - Remove OSX interposer. r=haik! → Bug 1682030 - Remove OSX interposer. r=haik!
Attachment #9206789 - Attachment description: Bug 1682030 - Remove NPAPI plugin support from accessible. r=marcoz! → Bug 1682030 - Remove NPAPI plugin support from accessible. r=marcoz!
Attachment #9206790 - Attachment description: Bug 1682030 - Remove some dead NPAPI code from dom/plugins and related spots. r=jmathies!,jld!,mconley! → Bug 1682030 - Remove some dead NPAPI code from dom/plugins and related spots. r=jmathies!,mconley!
Attachment #9206792 - Attachment description: Bug 1682030 - Remove NPAPI support from ClearDataService. r=baku! → Bug 1682030 - Remove NPAPI support from ClearDataService. r=baku!
Attachment #9206794 - Attachment description: Bug 1682030 - Remove NPAPI blocklisting r=gijs!,jmathies! → Bug 1682030 - Remove NPAPI blocklisting r=gijs!,jmathies!
Attachment #9206796 - Attachment description: Bug 1682030 - Remove more dead NPAPI code from dom/plugins and related spots. r=jmathies!,mconley!,emilio! → Bug 1682030 - Remove more dead NPAPI code from dom/plugins and related spots. r=jmathies!,mconley!,emilio!
Attachment #9206798 - Attachment description: Bug 1682030 - Remove NPAPI plugin async rendering support r=bas!,jld! → Bug 1682030 - Remove NPAPI plugin async rendering support r=bas!
Attachment #9206799 - Attachment description: Bug 1682030 - Remove NPAPI windowed plugin layer support r=bas! → Bug 1682030 - Remove NPAPI windowed plugin layer support r=bas!
Attachment #9206800 - Attachment description: Bug 1682030 - Remove CTP option from about:addons r=rpl! → Bug 1682030 - Remove CTP option from about:addons r=rpl!
Attachment #9206801 - Attachment description: Bug 1682030 - Remove NPAPI plugin reporting from crashreporter r=mconley! → Bug 1682030 - Remove NPAPI plugin reporting from HangMonitor r=mconley!
Attachment #9206802 - Attachment description: Bug 1682030 - Remove MIME type table from about:plugins r=gijs! → Bug 1682030 - Remove MIME type table from about:plugins r=gijs!
Attachment #9206803 - Attachment description: Bug 1682030 - Remove NPAPI overlay from JS Plugin actors r=gijs! → Bug 1682030 - Remove NPAPI overlay from JS Plugin actors r=gijs!
Attachment #9206804 - Attachment description: Bug 1682030 - Clean up NPAPI plugin fallback behavior. r=gijs!,jmathies!,emilio! → Bug 1682030 - Clean up NPAPI plugin fallback behavior. r=gijs!,jmathies!,emilio!

Removes Windows NPAPI process sandboxing code, including the code to establish a viable temp directory that was accessible by the sandboxed process.

Depends on D107159

Eliminates the NPAPI plugin process type from the GeckoChildProcess enum as part of NPAPI removal. In order to avoid altering enum values when updating the process list, the GECKO_PROCESS_TYPE macro has been updated to include the desired enum value. We want to resist altering the values as they need to be consistent e.g. in telemetry reports.

We also remove plugins from adjacent spots that need to maintain consistency with GeckoChildProcess -- most notably the nsICrashService.

Depends on D108688

Blocks: 1698959

Could you land approved revisions incrementally, seeking other reviewers, or separate patches to multiple bugs? This bug blocks some further cleanups.

Flags: needinfo?(davidp99)

Unfortunately, the patches are pretty tightly integrated, to avoid tediously maintaining code that was also soon to be deleted, so landing them piecemeal would be hard. I'll see what I can do about speeding up reviews but there isn't much left. If you've got something specific that's really urgent, and if there is a sane way to do it, I'm good with coordinating so you can land right away. Just LMK what you need.

Flags: needinfo?(davidp99)
Attachment #9206780 - Attachment description: Bug 1682030 - Remove NPAPI from tests outside of dom/plugins. r=jmathies!,gijs!,gsvelto! → Bug 1682030 - Remove NPAPI from tests outside of dom/plugins. r=cmartin!,gijs!,gsvelto!
Attachment #9206800 - Attachment description: Bug 1682030 - Remove CTP option from about:addons r=rpl! → Bug 1682030 - Remove CTP option from about:addons r=rpl!,gijs!
Attachment #9206789 - Attachment description: Bug 1682030 - Remove NPAPI plugin support from accessible. r=marcoz! → Bug 1682030 - Remove NPAPI plugin support from accessible. r=eeejay!

(In reply to David Parks [:handyman] from comment #87)

If you've got something specific that's really urgent, and if there is a sane way to do it, I'm good with coordinating so you can land right away. Just LMK what you need.

It is not so urgent, but I want to #define UNICODE everywhere in windows builds. Unfortunately, some legacy plugin code dislikes #define UNICODE. I do not want to find out the cause and fix it because I thought it will be removed soon anyway. If it is possible to remove (or at least stop building) the relevant code, that's great.

Pushed by daparks@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9c9c8b4998e2
Remove NPAPI from tests outside of dom/plugins.  r=Gijs,cmartin
https://hg.mozilla.org/integration/autoland/rev/a9cdf93c2662
Remove NPAPI from dom/plugins tests.  r=jmathies
https://hg.mozilla.org/integration/autoland/rev/580d857674c0
Remove PPluginSurface.   r=jmathies,bas
https://hg.mozilla.org/integration/autoland/rev/b80054e9805c
Remove PPluginWidget.   r=jmathies,ipc-reviewers,nika
https://hg.mozilla.org/integration/autoland/rev/b4b88cdc7993
Remove OSX interposer.  r=haik
https://hg.mozilla.org/integration/autoland/rev/5861b8166b10
Remove NPAPI plugin support from accessible.  r=eeejay
https://hg.mozilla.org/integration/autoland/rev/e90edd89430e
Remove some dead NPAPI code from dom/plugins and related spots.  r=jmathies,mconley,ipc-reviewers,mccr8
https://hg.mozilla.org/integration/autoland/rev/9c58d57c9e44
Remove nsIPluginDocument. r=jmathies,emilio
https://hg.mozilla.org/integration/autoland/rev/0e06ddeea3e2
Remove NPAPI support from ClearDataService.  r=baku
https://hg.mozilla.org/integration/autoland/rev/6253d7e1ce7d
Remove NPAPI plugins from telemetry  r=chutten
https://hg.mozilla.org/integration/autoland/rev/5e20d06952ba
Remove NPAPI blocklisting  r=Gijs,jmathies,mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/9143da258d0e
Remove nsIPluginWidget  r=jmathies
https://hg.mozilla.org/integration/autoland/rev/da94a91b35ae
Remove more dead NPAPI code from dom/plugins and related spots.  r=jmathies,mconley,emilio
https://hg.mozilla.org/integration/autoland/rev/6af6af3bc03a
Reduce nsMimeTypeArray and nsPluginArray to "constants"  r=jmathies
https://hg.mozilla.org/integration/autoland/rev/9adb2865adea
Remove NPAPI plugin async rendering support  r=bas,jgilbert,ipc-reviewers,mccr8
https://hg.mozilla.org/integration/autoland/rev/366e3e371858
Remove NPAPI windowed plugin layer support  r=bas
https://hg.mozilla.org/integration/autoland/rev/42b0621c2927
Remove CTP option from about:addons  r=mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/6af3410bdb93
Remove NPAPI plugin reporting from HangMonitor  r=mconley
https://hg.mozilla.org/integration/autoland/rev/2986c7e14349
Remove MIME type table from about:plugins  r=Gijs,mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/de9222dc8c31
Remove NPAPI overlay from JS Plugin actors  r=Gijs
https://hg.mozilla.org/integration/autoland/rev/259c45447ad9
Clean up NPAPI plugin fallback behavior.  r=jmathies,emilio
https://hg.mozilla.org/integration/autoland/rev/3eca76a6d639
Remove HiddenPluginEvent. r=jmathies,webidl,edgar
https://hg.mozilla.org/integration/autoland/rev/35ae60eea3c7
Remove Windows NPAPI plugin proccess sandbox r=bobowen
https://hg.mozilla.org/integration/autoland/rev/5b1644096477
Remove NPAPI plugin process from GeckoChildProcess r=jld,gsvelto

Backed out for bustage on ProcessHangMonitor.cpp and nsCOMPtr.h

backout: https://hg.mozilla.org/integration/autoland/rev/bd702683bc3c0e964f915158dd03b8662bed429d

push: https://treeherder.mozilla.org/jobs?repo=autoland&revision=5b1644096477381390c909a3fc2e96efc4170a4a&group_state=expanded&selectedTaskRun=AwnIHAsQSAGyLIKKQpE8RA.0

failure logs:

[task 2021-04-06T00:33:17.142Z] 00:33:17 ERROR - /builds/worker/checkouts/gecko/dom/ipc/ProcessHangMonitor.cpp:892:6: error: 'void {anonymous}::HangMonitorParent::UpdateMinidump(uint32_t, const nsString&)' defined but not used [-Werror=unused-function]
[task 2021-04-06T00:33:17.142Z] 00:33:17 INFO - void HangMonitorParent::UpdateMinidump(uint32_t aPluginId,
[task 2021-04-06T00:33:17.142Z] 00:33:17 INFO - ^~~~~~~~~~~~~~~~~
[task 2021-04-06T00:33:17.143Z] 00:33:17 INFO - cc1plus: all warnings being treated as errors
[task 2021-04-06T00:33:17.143Z] 00:33:17 ERROR - make[4]: *** [/builds/worker/checkouts/gecko/config/rules.mk:676: ProcessHangMonitor.o] Error 1
[task 2021-04-06T00:33:17.143Z] 00:33:17 INFO - make[4]: Leaving directory '/builds/worker/workspace/obj-build/dom/ipc'

[task 2021-04-06T00:07:55.956Z] In file included from /builds/worker/checkouts/gecko/dom/base/nsMimeTypeArray.h:11:
[task 2021-04-06T00:07:55.957Z] /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/dist/include/nsCOMPtr.h:424:5: error: no matching function for call to 'ToSupports'
[task 2021-04-06T00:07:55.958Z] NSCAP_LOG_ASSIGNMENT(this, aNewPtr);
[task 2021-04-06T00:07:55.959Z] ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[task 2021-04-06T00:07:55.960Z] /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/dist/include/nsISupportsImpl.h:182:49: note: expanded from macro 'NSCAP_LOG_ASSIGNMENT'
[task 2021-04-06T00:07:55.961Z] if (_p != nullptr) NS_LogCOMPtrAddRef((_c), ToSupports(_p))
[task 2021-04-06T00:07:55.962Z] ^~~~~~~~~~

Flags: needinfo?(davidp99)

Fortunately this looks to be just deleting an unused method and adding an #include missing in non-unified builds. Nothing deep at all -- should be back shortly.

Flags: needinfo?(davidp99)
Pushed by daparks@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1c07317c6dbf
Remove NPAPI from tests outside of dom/plugins.  r=Gijs,cmartin
https://hg.mozilla.org/integration/autoland/rev/080aa7b074c3
Remove NPAPI from dom/plugins tests.  r=jmathies
https://hg.mozilla.org/integration/autoland/rev/3739f10fd744
Remove PPluginSurface.   r=jmathies,bas
https://hg.mozilla.org/integration/autoland/rev/8f1aa45d854b
Remove PPluginWidget.   r=jmathies,ipc-reviewers,nika
https://hg.mozilla.org/integration/autoland/rev/11170fb7e7fe
Remove OSX interposer.  r=haik
https://hg.mozilla.org/integration/autoland/rev/4dba093cbb34
Remove NPAPI plugin support from accessible.  r=eeejay
https://hg.mozilla.org/integration/autoland/rev/29ce5e7ceaa6
Remove some dead NPAPI code from dom/plugins and related spots.  r=jmathies,mconley,ipc-reviewers,mccr8
https://hg.mozilla.org/integration/autoland/rev/a5d8b38876d8
Remove nsIPluginDocument. r=jmathies,emilio
https://hg.mozilla.org/integration/autoland/rev/d789ce825491
Remove NPAPI support from ClearDataService.  r=baku
https://hg.mozilla.org/integration/autoland/rev/32a2fdad82bb
Remove NPAPI plugins from telemetry  r=chutten
https://hg.mozilla.org/integration/autoland/rev/6e00aba7e14f
Remove NPAPI blocklisting  r=Gijs,jmathies,mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/ee8836383bf0
Remove nsIPluginWidget  r=jmathies
https://hg.mozilla.org/integration/autoland/rev/2e011ce4adbf
Remove more dead NPAPI code from dom/plugins and related spots.  r=jmathies,mconley,emilio
https://hg.mozilla.org/integration/autoland/rev/4639cb0ba184
Reduce nsMimeTypeArray and nsPluginArray to "constants"  r=jmathies
https://hg.mozilla.org/integration/autoland/rev/c76b18432fa2
Remove NPAPI plugin async rendering support  r=bas,jgilbert,ipc-reviewers,mccr8
https://hg.mozilla.org/integration/autoland/rev/ac573562d3df
Remove NPAPI windowed plugin layer support  r=bas
https://hg.mozilla.org/integration/autoland/rev/f2ad1724e9af
Remove CTP option from about:addons  r=mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/ee8b4ffc4aca
Remove NPAPI plugin reporting from HangMonitor  r=mconley
https://hg.mozilla.org/integration/autoland/rev/6999a4083233
Remove MIME type table from about:plugins  r=Gijs,mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/a0b2f4d23544
Remove NPAPI overlay from JS Plugin actors  r=Gijs
https://hg.mozilla.org/integration/autoland/rev/2155fb99d845
Clean up NPAPI plugin fallback behavior.  r=jmathies,emilio
https://hg.mozilla.org/integration/autoland/rev/36306d2ee01f
Remove HiddenPluginEvent. r=jmathies,webidl,edgar
https://hg.mozilla.org/integration/autoland/rev/654058730d71
Remove Windows NPAPI plugin proccess sandbox r=bobowen
https://hg.mozilla.org/integration/autoland/rev/196e52cf4488
Remove NPAPI plugin process from GeckoChildProcess r=jld,gsvelto
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/889adb90a583
comm-central packaging adjustments for bug 1682030. rs=bustage-fix
See Also: → 1377445
Regressions: 1704784
You need to log in before you can comment on or make changes to this bug.