alternate text is not displayed when accepting images coming from the originating server only

NEW
Unassigned

Status

()

Core
Image Blocking
P3
normal
16 years ago
9 months ago

People

(Reporter: Adam Hauner, Unassigned)

Tracking

(Depends on: 1 bug, {html4, testcase})

Trunk
Future
html4, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [HTML4-13.3.1])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Alternate text of image is not displayed when accepting images coming from the
originating server only. Same situation is with <INPUT TYPE="image">.

Repro:
1. go to Preferences | Privacy & Security | Images 
2. select 'Accept images that come from ...'
3. load any page which using images from another server

Actual:
Alternate text for tags is not displayed.

Expect:
Alternate text for tags is displayed.

2002091608/trunk/W2k
(Reporter)

Comment 1

16 years ago
Created attachment 99504 [details]
Testcase

Testcase containing tags IMG and INPUT (type=image) with src on
http://www.mozilla.org/. Alternate text is provided for both tags.
(Reporter)

Updated

16 years ago
Keywords: testcase

Comment 2

16 years ago
What do you mean? We don't show any 'alt' text at all, only 'title' tags. See
bug  25537.

Comment 3

16 years ago
--> INVALID

See bug 25537 comment 153
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
REOPEN: Sorry, my mistake, this bug is ALT for a missing image - not a tooltip. 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

16 years ago
This looks related to bug 63730 & bug 96976. 
->Image blocking
Assignee: asa → morse
Component: Browser-General → Image Blocking
Keywords: html4
QA Contact: asa → tever
Whiteboard: [HTML4-13.3.1]

Comment 7

16 years ago
I just tried to reproduce this using the setting 'Accept images that come from
...' with the testace. Both images were displayed. Strange.

pi

Comment 8

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021002

I see the problem as described in comment 0.

The testcase is as with Linux: both images displayed.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.3alpha
Mass reassigning of Image manager bugs to mstoltz@netscape.com, and futuring.
Most of these bugs are enhancement requests or are otherwise low priority at
this time.
Assignee: morse → mstoltz
Status: ASSIGNED → NEW
Target Milestone: mozilla1.3alpha → Future

Comment 10

16 years ago
*** Bug 192591 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
Bringing comments over from 192591

Mozilla fails to display alt text for images blocked when image blocking is in force

It is not specific to images from another server but any blocked image (ie
images blocked by "do not load any images")

This is a major accessabilty problem isn't it? 
Flags: blocking1.3?

Comment 12

16 years ago
Yes it is. One can't navigate through the site while image blocking is in force.

Comment 13

16 years ago
I think I've seen this before elsewhere... I'll do some searching

->All/All in the mean time
OS: Windows 2000 → All
Hardware: PC → All

Comment 14

16 years ago
found it

*** This bug has been marked as a duplicate of 41924 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Flags: blocking1.3?

Updated

15 years ago
QA Contact: tever → nobody

Comment 15

12 years ago
*** Bug 364492 has been marked as a duplicate of this bug. ***
For the sake of simplicity, reopening this bug and marking it depending on 41924 rather than dupe of.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

12 years ago
Depends on: 41924

Comment 17

12 years ago
Should this bug also cover blocked images?
Jesse, well I think that's the same thing, as this is automatically blocking pics based on relationship rather than by domain. I *think* I'd say that this one can cover all blocked images, and 41924 is for broken images, and then this depends on that if the fix is going to fix both.
Assignee: security-bugs → nobody
Status: REOPENED → NEW

Comment 19

11 years ago
Oh please fix this. It shouldn't be too hard since the functionality is there (if you choose to block ALL sites).
QA Contact: nobody → image-blocking

Comment 20

9 months ago
Is it still reproducible?
You need to log in before you can comment on or make changes to this bug.