Closed Bug 1692082 Opened 10 months ago Closed 9 months ago

Fix checkbox and radio menuitem styling

Categories

(Toolkit :: Themes, defect, P2)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: mhowell, Assigned: Gijs)

References

Details

(Keywords: helpwanted, Whiteboard: [proton-context-menus] )

Attachments

(1 file)

Checkboxes and radio buttons embedded in menus look pretty rough. We turned off the native style in bug 1682522 and replaced it with a generic checkmark icon (for both types of controls, which I honestly think might be fine), but it still needs more work to be presentable.

Whiteboard: [proton-context-menus]
Severity: -- → N/A
Priority: -- → P3
Duplicate of this bug: 1692273

I filed a JIRA ticket for this because there's no design for this.

(In reply to :Gijs (he/him) from comment #2)

I filed a JIRA ticket for this because there's no design for this.

FWIW, this isn't the JIRA that corresponds to this ticket, but https://jira.mozilla.com/browse/FIDEFE-245 .

Priority: P3 → P2

https://jira.mozilla.com/browse/FIDEFE-245 has been updated with the spec and icons to use.

Keywords: helpwanted

The spec seems tricky to implement in a way that won't lead to inconsistencies. We may have to always add leading padding to menuitems (this would be standard Windows behavior) or disable the new styling entirely if nobody picks this up in time.

Severity: N/A → S2
Component: Menus → Themes
Product: Firefox → Toolkit
Summary: Improve menu bar checkbox and radio button styling → Fix checkbox and radio menuitem styling
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6fbbdd2195e1
fix spacing, icons and colours for checkmarks and arrows in Windows 10 menus, r=jaws
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
You need to log in before you can comment on or make changes to this bug.