Closed Bug 1699134 Opened 9 months ago Closed 9 months ago

[Proton] Submenu icons for disabled options is not greyed out

Categories

(Firefox :: Menus, defect)

Firefox 88
All
Windows 10
defect

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- unaffected
firefox88 --- verified

People

(Reporter: bogdan_maris, Assigned: ntim)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [proton-context-menus])

Attachments

(2 files)

Affected versions

  • Latest Nightly 88.0a1

Affected platforms

  • Windows 10 64bit

Unaffected platforms

  • macOS 10.15
  • Ubuntu 18.04

Steps to reproduce

  1. Start Firefox
  2. Open a new blank tab
  3. Right click on the new tab

Expected result

  • Send Tab to Device option is disabled (greyed out) and so is the submenu > symbol.

Actual result

  • Send Tab to Device option is disabled but the submenu > symbol is not greyed out. Same for Send Page to Device.

Regression range

Additional notes

  • Screenshot showing the issue is attached.
  • Items from Menu Bar have the same issue.

Suggested severity

  • I would suggest having S3 severity for this bug, it is a noticeable bug but I don't think it's major enough to have it to S2.
Has Regression Range: --- → yes
Has STR: --- → yes
Whiteboard: [proton-context-menus]

--menu-icon-color should be removed and fill: currentColor + fill-opacity should be used instead. That would fix the issue in this bug.

Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Attachment #9209989 - Attachment description: Bug 1699134 - Remove --menu-icon-color in favor of currentColor & fill-opacity. r=jaws,dao → Bug 1699134 - Remove --menu-icon-color in favor of currentColor & fill-opacity.
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ed1f8ac0d787
Remove --menu-icon-color in favor of currentColor & fill-opacity. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Verified that this is fixed now in latest Nightly from Today.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.