Closed Bug 1692159 Opened 1 year ago Closed 8 months ago

Autofill Logins and passwords not working [maybe related to strange Enterprise Policies behaviour]

Categories

(Firefox :: Preferences, defect, P3)

Firefox 85
defect

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- wontfix
firefox89 --- wontfix
firefox90 --- fixed

People

(Reporter: bugzilla, Assigned: mkaply)

References

(Regression)

Details

(Keywords: regression, Whiteboard: QA-not-reproducible)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:85.0) Gecko/20100101 Firefox/85.0

Steps to reproduce:

The Enterprises Policies issue reported at https://support.mozilla.org/en-US/questions/1325482 may be related.

The "Autofill logins and passwords" preference is no longer being honoured.

Actual results:

Login forms which have entries in the unlocked Password Manager are not being auto-filled. They used to be autofilled, prior to the following Enterprise Policies being activated:

DisableFirefoxAccounts [true]
PasswordManagerEnabled [false]
OfferToSaveLogins [false]
OfferToSaveLoginsDefault [false]

Even after the first 2 Enterprise Policies being removed, the behaviour continues with only these Enterprise Policies being shown active:

OfferToSaveLogins [false]
OfferToSaveLoginsDefault [false]

Expected results:

Login fields matching entries in the Password Manager should be auto-filled.

The Bugbug bot thinks this bug should belong to the 'Firefox::Enterprise Policies' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Enterprise Policies

Are you sure we used to autofill passwords in that case? I think of OfferToSaveLogins is false, we don't offer and we don't autofill. I'll run some tests.

If you're sure this behavior is changed, can you see if you can use https://mozilla.github.io/mozregression/ to figure out when it changed?

Sorry, I conflated 2 issues with this bug submission, one of which was not a bug at all but my mistake.

It would appear setting OfferToSaveLogins prevents autofill. If this is expected behaviour then I’ll close the bug, but from my perspective I feel this might be documented better?

In https://github.com/mozilla/policy-templates#offertosavelogins the description is simply: “Control whether or not Firefox offers to save passwords.”

Hi Mike!
Could you confirm if what the reporter indicates in comment 5 is the expected behavior? If so, could the issue be closed?

Flags: needinfo?(mozilla)

Hi!
I think it might be an intended behavior and I will close this issue as Invalid. Mike if you consider it a valid issue please feel free to reopen it.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → INVALID
Whiteboard: QA-not-reproducible

That is the expected behavior. I'm updating the docs. Sorry for taking so long.

Flags: needinfo?(mozilla)

OK, I get this now and it's a bug in preferences.

If you set OfferToSaveLogins to false, the checkbox in preferences is still clickable and when you click it, it enables the two preferences below it.

I'm looking.

Status: RESOLVED → REOPENED
Component: Enterprise Policies → Preferences
Ever confirmed: true
Resolution: INVALID → ---
Severity: -- → S4
Priority: -- → P3

This was broken by bug 1620753.

Unfortunately the test for this policy only checked the pref, not the UI.

Regressed by: 1620753
Has Regression Range: --- → yes
Assignee: nobody → mozilla
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/5bca5dcbda04
Disable saved password preference if disabled by policy. r=mixedpuppy,preferences-reviewers
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
You need to log in before you can comment on or make changes to this bug.