Closed Bug 1692553 Opened 1 year ago Closed 1 year ago

Remove the "View page info" item from the page context menu

Categories

(Firefox :: Menus, enhancement)

Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox88 --- verified

People

(Reporter: Gijs, Assigned: masterwayz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-context-menus])

Attachments

(1 file)

For most users, this item is not useful, and removing it from the main context menu will make it easier to scan the context menu. More context and discussion happened in https://docs.google.com/presentation/d/1Ufd0A3HsziyXXAjXYNH84P2bu7RdTxARsA0xpKmwIWs/edit?ts=6011b061 . The page info window remains accessible via Tools > Page Info, the keyboard shortcut, and the identity block.

Whiteboard: [proton-context-menus]
Assignee: nobody → michelle
Status: NEW → ASSIGNED
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9be2f6747aeb
Remove "View page info" from page context menu r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Verified that View page info is no longer present in page context menu but is still available in Menu Bar and by accessing ctrl/cmd+i using latest Nightly 88.0a1 across platforms (Windows 10, macOS 11.3 and Ubuntu 18.04). Removing firefox87 tracking flag since this was planned for Firefox 88

Status: RESOLVED → VERIFIED

(In reply to :Gijs (he/him) from comment #0)

The page info window remains accessible via Tools > Page Info, the keyboard shortcut, and the identity block.

[Sad face] On SUMO, I routinely point users to the View Page Info context menu item to access the permissions panel to allow camera/microphone access or resolve other permission issues. (On Windows, the menu bar is not displayed by default.) Going through the security information route is circuitous at best.

Is there any work underway to make the site permissions panel easier to access?

(In reply to jscher2000 from comment #5)

(In reply to :Gijs (he/him) from comment #0)

The page info window remains accessible via Tools > Page Info, the keyboard shortcut, and the identity block.

[Sad face] On SUMO, I routinely point users to the View Page Info context menu item to access the permissions panel to allow camera/microphone access or resolve other permission issues. (On Windows, the menu bar is not displayed by default.) Going through the security information route is circuitous at best.

Is there any work underway to make the site permissions panel easier to access?

The keyboard shortcut (CTRL+i) as well as access through the "Lock icon" > Right Arrow > "More information" and the global OS toolbar entry "Tools/Page Info" obviously remain available.

Context on the motivation for the decision:

  • The use of context menus is key to the Firefox user experience, our intention here is to reduce entries with very low use in order to make it simpler for higher usage entries to be more easily discoverable.
  • The "View Page Info" entry has a mix of low engagement (lowest engagement on the menu) along with availability of several alternate entry points to the feature. Also other browsers don't have this option.
  • 84% of users who select "View page info" only do it once a month or less, which indicates that users either hit the entry to discover what it does or at least don't rely on it as a core workflow

I hope this helps clarify things, this change is designed with most users in mind and I hope it does not make it harder for you to keep helping people on SUMO.

According to https://support.mozilla.org/en-US/contributors/kb-overview and https://support.mozilla.org/en-US/contributors/most-visited
the Firefox Page Info window article is one of our top articles.

I updated https://support.mozilla.org/en-US/kb/firefox-page-info-window for Firefox 88 to replace the instructions to use the context menu with Menu bar instructions, taking into account that the Menu bar is not enabled by default for Windows and Linux.

(In reply to jscher2000 from comment #5)

(In reply to :Gijs (he/him) from comment #0)

The page info window remains accessible via Tools > Page Info, the keyboard shortcut, and the identity block.

[Sad face] On SUMO, I routinely point users to the View Page Info context menu item to access the permissions panel to allow camera/microphone access or resolve other permission issues. (On Windows, the menu bar is not displayed by default.) Going through the security information route is circuitous at best.

Is there any work underway to make the site permissions panel easier to access?

If there are any non-default permissions I'd expect the permissions icon to show up to the right of the lock icon, and list all such permissions, making them easy to revoke. If the page requested permissions that the user rejected, the icon for the relevant permission normally remains visible in the address bar. When do users need the page info dialog to manage permissions, in your experience?

Flags: needinfo?(jscher2000)

The most common reason for suggesting was that camera/microphone permission wasn't requested. Perhaps the site detected that it didn't have permission and redirected.

For users that have trouble adding cookie exceptions on about:preferences, I suggest adding them through the Permissions panel.

Others might have come up once to twice but those are the main ones.

Flags: needinfo?(jscher2000)

(In reply to jscher2000 from comment #9)

The most common reason for suggesting was that camera/microphone permission wasn't requested. Perhaps the site detected that it didn't have permission and redirected.

OK. If there's a pattern to what sites do this it may be worth filing a web compat bug or a bug in Firefox :: Site Identity Panel. I think ideally we should try to fix that experience so it doesn't require the page info dialog.

For users that have trouble adding cookie exceptions on about:preferences, I suggest adding them through the Permissions panel.

What kind of cookie exceptions are we talking about? Is this to clear cookies on shutdown but keep them for specific sites, or allowing tracking cookies on some domains, or...? And when you say the users have trouble adding exceptions, is this because there's an issue with the UI in the preferences, or is it to do with main domains vs subdomains, or something else?

Basically, for both of these, I think the right fix is likely making the other UI more usable / reliable, so people don't have to resort to page info. :-)

If you want to remove it by default, fine, but can we at least get an option to re-enable this? The way I do things, both alternative methods take longer, and I used this a significant amount every day. It's pretty frustrating not having this option anymore.

Like Gijs, I'd actually be interested in what exact use cases this has been supporting for people, so that we might be able to make those more easily available in other places :)

The General tab was extremely useful, but I used this primarily to browse through & view info about media on a page. It's significantly easier than having to inspect each thing, pick through the source, or use an add-on (which never quite accomplishes the same thing). I used this probably 100+ times a day, no exaggeration. Getting to this from the padlock icon is significantly slower, and I don't usually browse with my hands on the keyboard, so the "shortcut" is even more inconvenient.

Again, I get that the average user may not know what this is or have any use for it, and I totally get removing it by default. With the amount of available options in Firefox though, I don't get why an option can't exist to return this, especially considering how useful it is and how long it has existed in the browser.

(In reply to rex4748 from comment #14)

The General tab was extremely useful,

What for? What specific information in there is useful to you?

but I used this primarily to browse through & view info about media on a page. It's significantly easier than having to inspect each thing, pick through the source, or use an add-on (which never quite accomplishes the same thing).

What's your purpose in "viewing info about media on a page" ? That is, what are you trying to do with the information displayed there? Wouldn't it be more useful to have it overlaid on the page, and be able to activate/deactivate the overlay with a toolbar item or similar? That's something that should be relatively straightforward with an add-on... but again, we're still kind of guessing at your usecase here - do you care about the file names of the media? Sizes? Content types? What goals are you trying to accomplish?

I don't get why an option can't exist to return this, especially considering how useful it is and how long it has existed in the browser.

Because every option has a cost, and combinations of options have an even higher cost (e.g. trying to keep the access keys unique in the content context menu is already a nightmare, considering the number of different subsets of items can be shown simultaneously, and options make it worse). Doing so doesn't scale - we renamed (and thus sometimes changed access keys for) probably on the order of three dozen items, and removed a few others, in the last 2-3 months, and if we added an option for every single one (and yes, people are very unhappy even about some access key / labelling changes, cf. bug 1701324) , you can imagine how that stops making sense. I get it, you probably don't need the other three dozen options, so to you it's "just one option" - but likewise, the people who care about some of the other items might not care about "view page info", and to them too it's "just one option". To engineering (and the volunteer localizer community!) it ends up meaning "a lot of work, which makes future work even harder" (because it has to remain compatible with all the existing options).

The additional options in about:config also aren't discoverable - if page info is really a crucial tool for lots of people, it shouldn't require going to about:config to enable it.

(In reply to :Gijs (he/him) from comment #15)

What for? What specific information in there is useful to you?

Being able to copy/paste page titles as is, referrer, metatags- without having to pick through the source.

What's your purpose in "viewing info about media on a page" ? That is, what are you trying to do with the information displayed there?

Well, I use View Image Info quite a bit, and this lets me do it for each image on the page in one place, instead of selecting them all individually. Also useful for viewing info on/saving images that are hidden, set as backgrounds, altered with CSS, or can't be easily accessed outside of Inspect. I don't have one particular use case, I used this constantly for many reasons.

Wouldn't it be more useful to have it overlaid on the page, and be able to activate/deactivate the overlay with a toolbar item or similar? That's something that should be relatively straightforward with an add-on... but again, we're still kind of guessing at your usecase here - do you care about the file names of the media? Sizes? Content types? What goals are you trying to accomplish?

I've tried existing add-ons and other methods, and nothing matches the functionality and ease of use that this provided. All of this information is useful for different reasons. Having all this info about every piece of media overlaid on the page seems like it would be a little messy and unintuitive, but I'm having trouble visualizing how it would. I wish I could give you a better answer here, but I've used this so many times a day for years, and for so many different things, it's hard to be specific.

Because every option has a cost, and combinations of options have an even higher cost (e.g. trying to keep the access keys unique in the content context menu is already a nightmare, considering the number of different subsets of items can be shown simultaneously, and options make it worse). Doing so doesn't scale - we renamed (and thus sometimes changed access keys for) probably on the order of three dozen items, and removed a few others, in the last 2-3 months, and if we added an option for every single one (and yes, people are very unhappy even about some access key / labelling changes, cf. bug 1701324) , you can imagine how that stops making sense.

I understand, and that's fair enough. Things come and go with every release, I guess I'm just having trouble wrapping my head around this one in particular because it's been there for so long and I used it so often. If I'm in the minority, and including the option is not feasible, then I get it, and that's just how it goes.

Could you please re-add this? This was genuinely a good tool for casually finding and downloading elements from any given website. I used to use this for finding backgrounds, and going through the other options listed above are honestly kind of tedious. Failing that at least implement it somewhere else that's convenient.

Having upgraded from Firefox 85 to 89 in one shot, I find myself missing this feature, and particularly, in 89, it's not even in the global hamburger menu's "More tools >" submenu (and there is no "Tools" submenu) so it was almost impossible to find, I had to search-engine-my-way-to-here to find out about what happened to this feature. And I still can't find it in any menus, the best I was able to do was to click on the addressbar's padlock icon, then click on "Connection secure >", then click on "More Information", which is neither discoverable at all (nor efficient). It was so hard to find, I had a bit of a panic moment thinking the dialog/feature had been removed entirely.

Like rex above, I use this to be able to rip images & media off the page, including invisible/background/etc. images, without fighting with modern websites' gazillion overlays preventing you from clicking with precision on the thing you actually want to get, or only giving you low-resolution thumbnails instead of the full original version, etc.

I also use the Permissions tab of that dialog quite often now, to be able to add per-site exceptions (to block cookies for a specific website for example, or to pre-emptively authorize microphone/video on a videoconferencing website before my turn comes as a speaker in an important event, etc.).

(In reply to Jeff Fortin from comment #20)

Like rex above, I use this to be able to rip images & media off the page, including invisible/background/etc. images, without fighting with modern websites' gazillion overlays preventing you from clicking with precision on the thing you actually want to get, or only giving you low-resolution thumbnails instead of the full original version, etc.

You can toggle browser.menu.showViewImageInfo in about:config to return View Image Info to the menu, so you could access the Page Info media tab with a right-click on any image.

I have the same problem as Jeff Fortin, I couldn't find the "View Page Info" widget and had to google my way here.

I expected to find it in the Burger Menu's "More Tools" submenu but it's not there...

The option for browser.menu.showViewImageInfo does not work on every media displayed, a notable exception would be Amazon's users reviews containing pictures that can't be opened to a new tab (to enable "fullscreen" view) and doesn't show "View Image Info" in context menu either.

(In reply to leodagan from comment #22)

I expected to find it in the Burger Menu's "More Tools" submenu but it's not there...

That seems like a good place for it. Maybe file a new bug for that?

The option for browser.menu.showViewImageInfo does not work on every media displayed, a notable exception would be Amazon's users reviews containing pictures that can't be opened to a new tab (to enable "fullscreen" view) and doesn't show "View Image Info" in context menu either.

That is caused by transparent navigation panels (preview/next) superimposed in front of the image (many sites have this design). Firefox generally does not pierce through transparent elements to find images, links, or other interesting elements behind them, so that is why you don't get the additional context menu items.

As a workaround, you can look at an extension like behind! or my alternate Image Info extension:

there's also the aspects of audio and other content in web pages, view page media is the only way to find it easily depending on the scripts they are using in the site. Why was page info removed from the tools/more tools menu as well? I can understand wanting to simplify the right click menu, but hiding it away behind multiple clicks in the lock icon and a shortcut most people do not know is very strange.

(In reply to Danloebsl from comment #24)

Why was page info removed from the tools/more tools menu as well?

It wasn't; it's still in the menubar's "Tools" menu, and it was never in the hamburger menu or its "more tools" menu, so it wasn't removed from there.

(In reply to jscher2000 from comment #23)

(In reply to leodagan from comment #22)

I expected to find it in the Burger Menu's "More Tools" submenu but it's not there...

That seems like a good place for it. Maybe file a new bug for that?

Did this ever happen?

(In reply to :Gijs (he/him) from comment #25)

(In reply to jscher2000 from comment #23)

(In reply to leodagan from comment #22)

I expected to find it in the Burger Menu's "More Tools" submenu but it's not there...

That seems like a good place for it. Maybe file a new bug for that?

Did this ever happen?

No, I'm not really used to open new bug report.

(In reply to leodagan from comment #26)

(In reply to :Gijs (he/him) from comment #25)

(In reply to jscher2000 from comment #23)

(In reply to leodagan from comment #22)

I expected to find it in the Burger Menu's "More Tools" submenu but it's not there...

That seems like a good place for it. Maybe file a new bug for that?

Did this ever happen?

No, I'm not really used to open new bug report.

OK, I filed bug 1725369 for you.

See Also: → 1725369
Duplicate of this bug: 769472
You need to log in before you can comment on or make changes to this bug.