Closed Bug 1692593 Opened 10 months ago Closed 8 months ago

Jira drop-down menus flash white and black when Proton context menus are enabled

Categories

(Firefox :: Menus, defect, P2)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- disabled
firefox85 --- disabled
firefox86 --- disabled
firefox87 --- disabled
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: cpeterson, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-context-menus])

Steps to reproduce

I am testing on Windows 10 with dark mode enabled.

  1. Set browser.proton.contextmenus.enabled pref = true and restart Nightly.
  2. Log into Jira: https://jira.mozilla.com/projects/PI/
  3. Click Jira's blue "Create" button.
  4. A "Create Issue" popup will open.
  5. Scroll down to the "Firefox Release Train" drop-down menu (default value "None").
  6. Click "None" to open the drop-down menu.

Actual result

A long, skinny drop-down menu will open. It is initially empty and white. Then it flashes empty and black. Then the menu contents shows up.

Expected result

The drop-down menu should open more quickly and not flash between white and black.

OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop
Whiteboard: [proton-context-menus]
Severity: -- → S3
Priority: -- → P3
Assignee: nobody → mhowell
Status: NEW → ASSIGNED

As per guidance from Vicky, for tracking, we're marking all the bugs that people are working on as P1.

Priority: P3 → P1

Marking as P2. Per experience review we agreed to mark as P1 bugs only bugs that will block MR1.

Priority: P1 → P2

Dani Bodea, from QA team will investigate more this issue to see if it could be reproducible on other websites.

Initially, this appears to be caused by selecting the "Dark" in the "Choose your color" drop-down from the Colors section of Windows settings (or just the Dark default app mode, not the default Windows mode, if the "Custom" color is previously selected like here) AND setting browser.proton.contextmenus.enabled as true (and browser restart).

While checking whether this is a regression, it appears that it is an issue introduced with the implementation of Proton - context menu.

Further, I am investigating whether this issue is reproducing in other places, by checking test pages with different kinds of drop-downs and a set of top worldwide websites. These results will be logged here:
https://docs.google.com/spreadsheets/d/1fOn6S9N70zI15nBuNwtKfe_J6M-cwk06yhvbmw4HvRY/edit?usp=sharing

P.S. this Google Sheet above will be updated with test locations until the EOD and it is commentable with Mozilla accounts.

See Also: → 1699149

In conclusion to my testing, the very same issue (flashing black/white backgrounds or any other kind of epileptic triggers) was not observed on any of the websites tested, but some other proton-specific issues were observed (and logged in the Google Sheet above).
NI me if further testing is necessary.

See Also: → 1699399
Assignee: mhowell → nobody
Status: ASSIGNED → NEW

I think bug 1699399 should have fixed this - we should now honour JIRA's colour schemes (which is black-text on a white background), and though JIRA changes the colours used for the context menu subtly as/when it comes up which originally caused the flashing, so you may still be able to see those subtle changes if checking very closely. Chris, can you confirm?

Flags: needinfo?(cpeterson)
Flags: needinfo?(cpeterson)

(In reply to :Gijs (he/him) from comment #6)

I think bug 1699399 should have fixed this - we should now honour JIRA's colour schemes (which is black-text on a white background), and though JIRA changes the colours used for the context menu subtly as/when it comes up which originally caused the flashing, so you may still be able to see those subtle changes if checking very closely. Chris, can you confirm?

I can no longer reproduce the flashing menus. Resolving as fixed.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED

Thanks!

Target Milestone: --- → 89 Branch
See Also: → 1702258

Reproduced the initial issue described in comment 0 using an old Nightly from 2021-03-18, verified that using latest Nightly this is no longer an issue.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.