Closed Bug 1692815 Opened 8 months ago Closed 6 months ago

Crash in [@ brush_image_TEXTURE_2D_frag::brush_fs]

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: gsvelto, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/8d6403c5-ec9c-4cb7-826b-64d390210215

Reason: EXCEPTION_ACCESS_VIOLATION_READ

Top 10 frames of crashing thread:

0 xul.dll brush_image_TEXTURE_2D_frag::brush_fs x86_64-pc-windows-msvc/release/build/swgl-40828f65300b0388/out/brush_image_TEXTURE_2D.h:779
1 xul.dll static brush_image_TEXTURE_2D_frag::run x86_64-pc-windows-msvc/release/build/swgl-40828f65300b0388/out/brush_image_TEXTURE_2D.h:829
2 xul.dll draw_quad_spans<unsigned int> gfx/wr/swgl/src/gl.cc:4339
3 xul.dll draw_quad gfx/wr/swgl/src/gl.cc:4935
4 xul.dll DrawElementsInstanced gfx/wr/swgl/src/gl.cc:5055
5 xul.dll swgl::swgl_fns::{{impl}}::draw_elements_instanced gfx/wr/swgl/src/swgl_fns.rs:1645
6 xul.dll webrender::renderer::Renderer::draw_instanced_batch<webrender::gpu_types::PrimitiveInstanceData> gfx/wr/webrender/src/renderer/mod.rs:2509
7 xul.dll webrender::renderer::Renderer::draw_alpha_batch_container gfx/wr/webrender/src/renderer/mod.rs:2885
8 xul.dll webrender::renderer::Renderer::draw_frame gfx/wr/webrender/src/renderer/mod.rs:4476
9  @0x402e1febff 

This appears to be a crash on machines running WebRender's software back-end. It seems to affect both Windows and Linux so I guess it's not platform-dependent (which makes sense given it's happening in a software-only path).

Severity: -- → S3
Blocks: gfx-triage

I can reproduce this.

See Also: → 1692029
See Also: 1692029

Bug 1692029 might fix this once it lands.

No longer blocks: gfx-triage

(In reply to Lee Salzman [:lsalzman] from comment #2)

Bug 1692029 might fix this once it lands.

This work landed in 88. Crashes showing up in early beta in 87. We'll see if the fix helped after the next merge.

Duplicate of this bug: 1694451

Crashes have mostly disappeared here, so it seems like we fixed it.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Crash Signature: [@ brush_image_TEXTURE_2D_frag::brush_fs] → [@ brush_image_TEXTURE_2D_frag::brush_fs] [@ blendTextureLinearFallback<T>]
Crash Signature: [@ brush_image_TEXTURE_2D_frag::brush_fs] [@ blendTextureLinearFallback<T>] → [@ brush_image_TEXTURE_2D_frag::brush_fs] [@ blendTextureLinearFallback<T>] [@ blendTextureLinear<T>]
You need to log in before you can comment on or make changes to this bug.