Closed Bug 1693384 Opened 10 months ago Closed 7 months ago

WebRTC camera and active playback icon spacing should be optimized for Proton

Categories

(Firefox :: Theme, enhancement, P2)

enhancement
Points:
3

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox87 --- disabled
firefox88 --- disabled
firefox89 --- verified
firefox90 --- verified

People

(Reporter: soeren.hentzschel, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-tabs-bar][priority:2a] [proton-uplift])

Attachments

(2 files)

Attached image screenshot

(filed as requested on chat.mozilla.org)

As you can see in the attached screenshot there is almost no spacing between the PIP and the active playback icons in the Proton tab. The colors are also very different but I am not sure if you see this as a problem. I can't propose a concrete solution but I guess something should be done to achieve a visual more appealing result for the active playback + picture in picture use case.

Priority: -- → P5

This should get fixed by fixing bug 1693066.

Depends on: 1693066
Severity: -- → S4
Points: --- → 3
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Whiteboard: [proton-tabs-bar] → [proton-tabs-bar][fixed by bug 1693066]

We could probably add a pixel or two more separation here.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: PIP and active playback icon spacing should be optimized for Proton → PIP (picture-in-picture) and active playback icon spacing should be optimized for Proton
Priority: P5 → P3

Since bug 1693066, we no display a Picture In Picture icon, and we place all media icons (muted, playing, autoplay blocked) in the center of the favicon area, so this bug is now fixed/invalid.

Status: REOPENED → RESOLVED
Closed: 9 months ago8 months ago
Resolution: --- → INVALID
Resolution: INVALID → FIXED

I missed the case of audio playing with WebRTC active.

See https://webrtc.github.io/samples/src/content/devices/input-output/ to reproduce.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Summary: PIP (picture-in-picture) and active playback icon spacing should be optimized for Proton → WebRTC camera and active playback icon spacing should be optimized for Proton
Priority: P3 → P2
Whiteboard: [proton-tabs-bar][fixed by bug 1693066] → [proton-tabs-bar][fixed by bug 1693066] [priority:2a]
Whiteboard: [proton-tabs-bar][fixed by bug 1693066] [priority:2a] → [proton-tabs-bar][priority:2a]
Duplicate of this bug: 1706122
Assignee: nobody → jaws
Status: NEW → ASSIGNED

Also update the icons to add background strokes when used as an overlay.

Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b8f7bee95415
Move over pinned and overlay audio icon to move it away from the tab title. r=desktop-theme-reviewers,harry
Flags: needinfo?(jaws)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d69d822f586
Move over pinned and overlay audio icon to move it away from the tab title. r=desktop-theme-reviewers,harry
Duplicate of this bug: 1706994
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f57b728d597b
Move over pinned and overlay audio icon to move it away from the tab title. r=desktop-theme-reviewers,harry
Status: ASSIGNED → RESOLVED
Closed: 8 months ago7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9218454 [details]
Bug 1693384 - Move over pinned and overlay audio icon to move it away from the tab title.

Beta/Release Uplift Approval Request

  • User impact if declined: Required for MR1/Proton
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open and play a YouTube video
    Pin the tab
    Check that the playing icon is not positioned awkwardly over the site favicon
    Hover the icon and make sure that nothing looks out of the ordinary
    Mute the tab
    Check that the muted icon is not positioned awkwardly over the site favicon
    Hover the icon and make sure that nothing looks out of the ordinary
    Unpin the tab
    Go to https://webrtc.github.io/samples/src/content/devices/input-output/
    Check that the audio playback icon has enough space separation between the icon and the site label
    Hover the icon and make sure that nothing looks out of the ordinary

Repeat the above in the Light and Dark theme

  • List of other uplifts needed: Bug 1706096
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS and icon changes only
  • String changes made/needed: none
Flags: needinfo?(jaws)
Attachment #9218454 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]
Whiteboard: [proton-tabs-bar][priority:2a] → [proton-tabs-bar][priority:2a] [proton-uplift]

Playing icon on pinned tabs looks the same as before but with a different icon which looks a bit smaller. The "awkward positioning" over the site favicon still persists since we aren't aware of other type of positioning that we should expect.

Due to the new small playing/mute icon you barely could see if the tab is muted or unmuted especially on macOS.
On Ubuntu using system theme playing/mute icon is not visible. Logged a new bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1708154

I confirm that the audio playback icon has enough space separation between the icon and the site label on Windows 10 x64, macOS 10.15, Ubuntu 20.04 and on Windows 7 x64.

Flags: needinfo?(jaws)

Comment on attachment 9218454 [details]
Bug 1693384 - Move over pinned and overlay audio icon to move it away from the tab title.

Approved for 89 beta 6, thanks.

Attachment #9218454 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

(In reply to Hani Yacoub from comment #15)

Due to the new small playing/mute icon you barely could see if the tab is muted or unmuted especially on macOS.
On Ubuntu using system theme playing/mute icon is not visible. Logged a new bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1708154

Thanks, I'll investigate Ubuntu.

Flags: needinfo?(jaws)

Also logged bug 1708426 can't clearly distinguish if the pinned tab is playing or muted.

Duplicate of this bug: 1706808

Verified as fixed on Windows 10 x64, macOS 10.15, Ubuntu 20.04 and on Windows 7 x64.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.