Closed Bug 1693854 Opened 2 months ago Closed 2 months ago

Browser console doesn't list expected content (Windows 10)

Categories

(DevTools :: Console, defect)

Firefox 87
Desktop
Windows 10
defect

Tracking

(firefox-esr78 unaffected, firefox85 unaffected, firefox86 unaffected, firefox87 verified, firefox88 verified)

VERIFIED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox85 --- unaffected
firefox86 --- unaffected
firefox87 --- verified
firefox88 --- verified

People

(Reporter: aflorinescu, Assigned: ochameau)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Description:]

Browser console shows blank: no debug/logging messages, although the logs are enabled from config.

[Environment:]

Windows 10 / 87.0a1 2021-02-19
not reproducible Mac 10.14.6 and Ubuntu 20.04 / 87.0a1 2021-02-19

[Steps:]
  1. New profile.
  2. Start up Firefox.
  3. Open about:config:
    set app.normandy.logging.level to 0
    set browser.search.log to true
  4. Close and reopen the browser.
  5. Open browser console (Ctrl+Shift+J)
[Actual Result:]

Blank browser console.

[Expected Result:]

At least the logs for search and normandy should be listed.

[Regression Range:]

Bug 1642599 - [devtools] Enable all console messages server support everywhere. r=ochameau.

Summary: Browser console doen't list expected content (Windows 10) → Browser console doesn't list expected content (Windows 10)
Severity: -- → S3

Bug 1642599 should be backed out and revisited. This breaks console resources for content process targets.
That's because resource-available-form event isn't declared on content process targets:
https://searchfox.org/mozilla-central/source/devtools/shared/specs/targets/content-process.js#35-43
Registering the events will highlight more work because bug 1642599's patch will spawn duplicated messages as per:
https://phabricator.services.mozilla.com/D103285#3357864

Assignee: nobody → poirot.alex

The missing resource-available-form event on content process target specifications
break console resources for content process targets.
Adding this event will probably create duplicate and so requires some more analysis.

:ochameau, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(poirot.alex)
Flags: needinfo?(poirot.alex)
Regressed by: 1642599
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8d436555d763
Disable console resources in targets other than tabs. r=nchevobbe
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

The patch landed in nightly and beta is affected.
:ochameau, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(poirot.alex)

(In reply to Release mgmt bot [:sylvestre / :calixte / :marco for bugbug] from comment #6)

The patch landed in nightly and beta is affected.
:ochameau, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

yes, let's uplift, I'll do the request

Flags: needinfo?(poirot.alex)

Comment on attachment 9204520 [details]
Bug 1693854 - Disable console resources in targets other than tabs.

Beta/Release Uplift Approval Request

  • User impact if declined: Some messages won't be visible in the Browser Console
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): A flag that we flipped during the 87 cycle was reverted to its original value, and a test was added
  • String changes made/needed:
Attachment #9204520 - Flags: approval-mozilla-beta?

Comment on attachment 9204520 [details]
Bug 1693854 - Disable console resources in targets other than tabs.

Approved for 87.0b3.

Attachment #9204520 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Duplicate of this bug: 1694977

verified fix with WIndows10 64bit, Macos 10.15 and ubuntu 20
using Firefox beta 87.0b5 & Firefox Nightly 88.0a1

browser console now shows data.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.