Closed Bug 1694404 Opened 2 years ago Closed 2 years ago

Pages load slowly when uBlock Origin is installed

Categories

(Core :: Networking, defect)

Firefox 85
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: logithack, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.183 Safari/537.36

Steps to reproduce:

I can reproduce by following these steps:

*** Profiles ***

*** Additional info ***

  • OS: Windows 10 Enterprise (1909)
  • Firefox version: 85.0.2
  • uBlock version: v1.33.2
  • Related issue https://bugzilla.mozilla.org/show_bug.cgi?id=1684703#c17 does not apply since my monitor uses 60 Hz.
  • Google Chrome + uBlock Origin installed do not cause the problem.
  • Similarly purposed extensions (e.g. AdBlock Plus) in Firefox do not cause this problem.
  • If uBlock is not installed, the problem does not occur.
  • If uBlock is installed but disabled, the problem does not occur.
  • When a page is loaded, it loads slowly. When loaded again - no matter if via pressing F5 or Ctrl+F5 - it loads fast.
  • Also, when browsing to another page (which will load slowly) and then loading the first page again, that first page will load fast. When Firefox is closed and re-opened, that same page will load slowly once again. That is, for example:
    (1) load https://www.debian.org [loads slowly]
    (2) load https://www.youtube.com [loads slowly]
    (3) load https://www.debian.org again [loads fast]
    (4) close and re-open Firefox
    (5) load https://www.debian.org again [loads slowly once; loads fast the next time it is queried]

Actual results:

The page takes about 10 seconds to load (see screenshot attached).

Expected results:

The page should have loaded much more quickly, i.e. < 2-3 sec.

The Bugbug bot thinks this bug should belong to the 'Core::DOM: Navigation' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → DOM: Navigation
Product: Firefox → Core
Component: DOM: Navigation → Networking

Thank you for the report. I followed the steps, so I couldn't reproduce the issue.

Could you help us diagnose the problem by:

  1. Capturing some HTTP logs: https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging
  2. Check if it also happens with nightly: https://nightly.mozilla.org/
  3. If this worked with Firefox 84, you can use mozregression to help us identify the cause: https://mozilla.github.io/mozregression/quickstart.html
Flags: needinfo?(logithack)

I've captured some HTTP logs as requested. Since they might contain sensitive data, I've asked Valentin for advice. He recommended sharing the logs with him directly. Therefore, I've just sent them to him via email.

Flags: needinfo?(logithack)

I've forgot to respond to step 2) and 3) you've proposed, sorry.

Step 2 (nightly): The issue I've described occurs on my PC at work, where Firefox is pre-installed. Installing software requires administrator rights, which employees don't have. Therefore, I'm unfortunately unable to install Firefox nightly builds.

Step 3 (Firefox 84): I cannot tell whether the problem does not occur with Firefox 84. However, I'm fairly sure that it would be the same since I was able to reproduce it with Firefox 83.0. (83.0 is installed; the instance with 85.0.2 I've mentioned in my bug report is a portable one for testing and I get exactly the same problem with that one.)

Flags: needinfo?(valentin.gosu)

@logithack,

There are reports of such slowness when the browser is configured to go through a proxy. Is this your case? If so, maybe try to toggle uBO's advanced setting cnameUncloak to false.

@Raymond

This did the trick. All pages are loading fast again. Thanks a lot!

Since this proves it's no bug in Firefox, this issue can be closed. (I'm not sure whether closing as "INVALID" is the correct thing to do here. I'd like to ask Bugzilla support to close this issue in a manner considered appropriate.)

Edit: I've just found the option to close it as "RESOLVED" with the flag "WORKSFORME". I'll do that now.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(valentin.gosu)
You need to log in before you can comment on or make changes to this bug.