Closed Bug 1694785 Opened 7 months ago Closed 7 months ago

Upgrade Linux builders to Debian buster

Categories

(Firefox Build System :: Task Configuration, task)

task

Tracking

(firefox88 fixed)

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(3 files, 1 obsolete file)

No description provided.
Depends on: 1694318
Depends on: 1694901

We're going to need them for -dbgsym packages shortly.

This requires a backport of valgrind to buster instead of jessie (which
we don't need a backport for anymore). Somehow the buster-based
android-build was using the backport for jessie. It now can use the
backport for buster.

Because we use sysroots, this makes no difference to the shipped builds.
This allows to remove the debian8-amd64-build docker image.

See Also: → 1694845
Attachment #9205328 - Attachment is obsolete: true
Blocks: 1695118

Like in bug 1694784, I verified that this doesn't change anything in the resulting shippable builds. The Linux32 ones are bit-identical, but the Linux64 ones have differences only in llvm-specific non-exported symbol names, which doesn't matter.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/c4da2e122b22
Add debian-debug archive to apt sources in docker images. r=firefox-build-system-reviewers,sheehan,mhentges
https://hg.mozilla.org/integration/autoland/rev/4a83eaa5975c
Upgrade Debian-based docker images to a more recent snapshot. r=firefox-build-system-reviewers,mhentges
https://hg.mozilla.org/integration/autoland/rev/cfa6aa28260c
Upgrade Linux builders to Debian buster. r=firefox-build-system-reviewers,mhentges
Regressions: 1695889
Blocks: 1706543
You need to log in before you can comment on or make changes to this bug.