Closed Bug 1695622 Opened 1 year ago Closed 1 year ago

Firefox 86 print preview does not work

Categories

(Toolkit :: Printing, defect)

Firefox 86
defect

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox88 --- verified

People

(Reporter: zdnexnet, Assigned: evilpie, NeedInfo)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0

Steps to reproduce:

  1. Install firefox 85/86 on linux (ubuntu 18.04)
  2. open any page
  3. click hamburger menu > print preview
  4. wait for print (old version was immediate 1sec)

Actual results:

Waiting several hours and nothing printed and previewed. Still loading dialog and Preparing preview.... :(

Expected results:

It should show print in 1 sec as this happened in previus version (ESR 78 or 84?)

Component: Untriaged → Printing
Product: Firefox → Toolkit

How this can be fixed? Currently I cannot print on this new version of Firefox. This is bad as I was just showing one that Firefox can be viable option, but then we had to print something and I was not able. Was this expected for new version, that some users will not be able to print?

Hi

I have then same issues (bug 1694844).
I think that in my case it is caused by not having a printer installed (I use Print to PDF file).

The Browser console shows this exception error:
Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIPrinterList.systemDefaultPrinterName]

I have several printers and also default printer set. So I guess it is either different bug or it is not connected to printer itself.

Can you open the browser console and see if there any relevant errors? I would suggest the following

  1. hamburger menu > web developer > browser console
  2. clear all messages by clicking on the trash bin in the top left
  3. Try to print any page
  4. Go back to the console
Flags: needinfo?(zdnexnet)

This is error what is created. But as I have said I was normally printing before and also in ESR version it works normally.

Uncaught (in promise) TypeError: paper is undefined getMarginPresets chrome://global/content/print.js:958
getMarginPresets chrome://global/content/print.js:986
get chrome://global/content/print.js:1310
updateSettings chrome://global/content/print.js:673
init chrome://global/content/print.js:321
async* chrome://global/content/print.js:91
EventListener.handleEvent* chrome://global/content/print.js:88

Flags: needinfo?(zdnexnet)

Should getMarginPresets handle paper being undefined ? i.e. by using paper?.unwriteableMarginTop. We end up here via getMarginPresets("default", paper), so we should fallback to the defaultSettings anyway.

Flags: needinfo?(sfoster)

If I try to print a page that is behind basic authentication, Firefox prompts for my login credentials again, then closes the print preview window. The print button will then be unresponsive unless I restart Firefox.

Well I guess that is different problem as this bug is about printing on all pages. Not ones behind auth request.

Btw I guess the system for print should be set same way as it was before, when it was normally working, right?

(In reply to Tom Schuster [:evilpie] from comment #6)

Should getMarginPresets handle paper being undefined ? i.e. by using paper?.unwriteableMarginTop. We end up here via getMarginPresets("default", paper), so we should fallback to the defaultSettings anyway.

Yeah I've run into this in another bug. Handling undefined paper is probably a good idea. Although an undefined paper object isn't expected and might be a indication of another bug upstream, its true that we don't strictly need the paper object to produce those margin values.

Flags: needinfo?(sfoster)

(In reply to mackilvane from comment #7)

If I try to print a page that is behind basic authentication, Firefox prompts for my login credentials again, then closes the print preview window. The print button will then be unresponsive unless I restart Firefox.

Could you file this as its own separate bug? It sounds like something we should look into, but its going to get lost posted as comment here.

Flags: needinfo?(mackilvane)
Assignee: nobody → evilpies
Flags: needinfo?(zdnexnet)

ok, this seems to work, but I am not sure how to properly test it as I had to use empty profile with just imported prefs. Then print preview opened. I did not try print itself. Anyway I guess I will have to copy profile and try it with that to see how it behaves.

Flags: needinfo?(zdnexnet)

Thanks for checking it out! Does this problem not reproduce on Firefox 86 with a new profile?

On new profile in 86 when I put print it first starts with previus preview (old one) which works and then when I do it again it shows new but again does not finish preview itself and in console it shows same error.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

So can this fix be included in Firefox release? As currently I was trying to change the printing on my normal profile and I was not able. Btw can I somehow deactivate new dialog to be able to print or I need to wait for fix?

Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46b85a9cb1f1
Gracefully handle missing paper when trying to getMarginPresets. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Should I test this somehow?

Regressions: 1699231
Flags: qe-verify+
No longer regressions: 1699231

(In reply to zdnex from comment #19)

Should I test this somehow?

Hello! Can you please test if the issue is fixed with Firefox 88.0b9 / https://www.mozilla.org/en-US/firefox/channel/desktop/. I tried reproducing the issue on Ubuntu 18.04 following STR from comment 0 but with no luck.
Thank you in advance!

Flags: needinfo?(zdnexnet)

Hello,
i am not sure if it is fixed, but now printing seems to be working.

Flags: needinfo?(zdnexnet)

Closing this based on comment 21.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.