Closed Bug 1695680 Opened 11 months ago Closed 3 months ago

touch problem when using STG

Categories

(WebExtensions :: General, defect)

Firefox 86
Desktop
Windows 10
defect

Tracking

(firefox86 affected, firefox87 affected, firefox88 affected, firefox89 affected, firefox90 affected, firefox91 affected, firefox92 affected, firefox93 affected, firefox94 affected)

RESOLVED DUPLICATE of bug 1696786
Tracking Status
firefox86 --- affected
firefox87 --- affected
firefox88 --- affected
firefox89 --- affected
firefox90 --- affected
firefox91 --- affected
firefox92 --- affected
firefox93 --- affected
firefox94 --- affected

People

(Reporter: none_and_none, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0

Steps to reproduce:

problem when using Simple Tab Groups v4.7

there are two problems:

  1. touch, cannot open tab list of group
  2. long touch, group list is closed, and somethings of firefox are no response a short time

== reproduce ==
problem 1:

  1. touch on simple tab groups icon
  2. group list is opened
  3. touch on part which will show tabs list of group
  4. group list is closed

problem 2:

  1. touch on simple tab groups icon
  2. group list is opened
  3. long touch on group list
  4. group list is closed
  5. no response when touch on any toolbar item, also page cannot be scroll
  6. after a short time, 'no response' is gone

Expected results:

for problem 1:
tab list of group should be show
where group list will not be closed

for problem 2:
context menu will be opened

reference:
https://github.com/Drive4ik/simple-tab-groups/issues/780

I was able to reproduce the first problem (but not the second one) on the latest versions of Firefox Nightly 88.0a1 (2021-03-03), beta 87.0b5 and release 86.0 on a Lenovo Yoga device.

Setting up flags and adding a component for this issue in order to get the dev team involved.
If you feel it's an incorrect one please feel free to change it to a more appropriate one.

This looks like a regression since in 80.0 it cannot be reproduced.

Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Product: Firefox → WebExtensions
OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop

Hello,
These are the results for the regression:

2021-03-10T12:34:32.869000: DEBUG : Found commit message:
Bug 1694575 - Don't include mozalloc.h from the iosfwd wrapper. r=andi

See Also: → 1696786

(In reply to Andrei Purice from comment #2)

Hello,
These are the results for the regression:

2021-03-10T12:34:32.869000: DEBUG : Found commit message:
Bug 1694575 - Don't include mozalloc.h from the iosfwd wrapper. r=andi

The change in the patch landed from Bug 1694575 doesn't seem relevant, would you mind to give it another try to bisect using mozregression?

Flags: needinfo?(andrei.purice)

(In reply to Luca Greco [:rpl] [:luca] [:lgreco] from comment #3)

(In reply to Andrei Purice from comment #2)

Hello,
These are the results for the regression:

2021-03-10T12:34:32.869000: DEBUG : Found commit message:
Bug 1694575 - Don't include mozalloc.h from the iosfwd wrapper. r=andi

The change in the patch landed from Bug 1694575 doesn't seem relevant, would you mind to give it another try to bisect using mozregression?

i have tried mozregression gui and get the final output:

app_name: firefox
build_date: 2020-12-15 00:17:31.374000
build_file: C:\Users\user.mozilla\mozregression\persist\15da94c6a7b1-shippable--autoland--target.zip
build_type: integration
build_url: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/bA-mdWsURRisbTZYY4k29Q/runs/0/artifacts/public%2Fbuild%2Ftarget.zip
changeset: 15da94c6a7b19f971d3dffaa4cab8edb8e41cb62
pushlog_url: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=87d37f9061c70268edfe1db3aa111c288e56b078&tochange=15da94c6a7b19f971d3dffaa4cab8edb8e41cb62
repo_name: autoland
repo_url: https://hg.mozilla.org/integration/autoland
task_id: bA-mdWsURRisbTZYY4k29Q

remark:
i just check the version is 85 or 86
if it is 85, i click 'good' else i click 'bad'

hope this help

Hey Luca,
I ran a new bisection and found this :
2021-06-07T12:10:49.934000: DEBUG : Found commit message:
Bug 1649611: Remove OS.File usage from DownloadIntegration.jsm and respect umask in IOUtils::SetPermissions r=barret

Flags: needinfo?(andrei.purice)

Test on Windows with touchscreen.

Flags: needinfo?(tomica)

Just tested original STR, this seems to be fixed after bug 1696786, but feel free to reopen if missed something.

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(tomica)
Resolution: --- → DUPLICATE
Duplicate of bug: 1696786

thanks

problem is solved
according to https://bugzilla.mozilla.org/show_bug.cgi?id=1696786#c17

You need to log in before you can comment on or make changes to this bug.