Closed Bug 1697053 Opened 1 month ago Closed 26 days ago

Let non-native theme ride to Beta and Release (in 89)

Categories

(Core :: Widget, task, P3)

task

Tracking

()

RESOLVED FIXED
89 Branch
Fission Milestone M8
Tracking Status
relnote-firefox --- ?
firefox-esr78 --- wontfix
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 + fixed

People

(Reporter: cpeterson, Assigned: emilio)

References

(Blocks 1 open bug)

Details

(Whiteboard: fission-nnt)

Attachments

(1 file)

We currently plan to let non-native theme ride the trains in 89. We don't need to do anything for this in 88 Nightly or Beta (though the Fission team might enable non-native theme early for macOS users in a Fission Beta experiment in 88 Beta).

This bug no longer needs to block the Fission M7a Beta experiment. In bug 1697055, kmag enabled non-native theme for users in the Fission experiment.

Non-native theme will ship in 89, well before our Fission M8 Release experiment.

Fission Milestone: M7a → M8
See Also: → 1697055

Please ni? me on bugs you actually want me to take, otherwise I might miss them :)

ni? for https://phabricator.services.mozilla.com/D109555#3559654. In particular, the reasoning is that if something would cause us to turn off nnt by default on release, we probably would also want to do that for fissuon users? But again I can leave the code if you want.

Flags: needinfo?(cpeterson)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd0820378114
Let non-native-theme ride the trains in Firefox 89. r=cpeterson,mstange

(In reply to Emilio Cobos Álvarez (:emilio) from comment #4)

ni? for https://phabricator.services.mozilla.com/D109555#3559654. In particular, the reasoning is that if something would cause us to turn off nnt by default on release, we probably would also want to do that for fissuon users? But again I can leave the code if you want.

LGMT. No need to keep the special case for Fission.

Flags: needinfo?(cpeterson)
Status: NEW → RESOLVED
Closed: 26 days ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Hi Emilio, does it require a mention in our 89 release notes? If it does, could you request it please? Is that on all platforms?
Thanks

Flags: needinfo?(emilio)

@ Emilio, feel free to suggest any changes to my proposed wording below!

Release Note Request (optional, but appreciated)

[Why is this notable]: The non-native theme (for web form controls) will be visible to users. Also, it may cause webcompat issues if web pages make assumptions about the dimensions or styling of form controls.

[Suggested wording]: I think this feature is relevant for the release note's "New" section.

Introducing a non-native implementation of web form controls, which delivers a new modern design and some improvements to page load performance. Watch for layout bugs in web pages that make assumptions about the dimensions or styling of form controls.

[Links (documentation, blog post, etc)]: Not at this time. I'm talking with Proton PM about maybe mentioning non-native theme in a Proton UX blog post.

relnote-firefox: --- → ?

Sounds good, thanks Chris.

Flags: needinfo?(emilio)

Added to nightly release notes with the suggested wording, thanks

Duplicate of this bug: 649948
Duplicate of this bug: 1615105

Pascal, the non-native theme is also relevant for Android's release notes for 89.0a1. Do I need to flag this bug in a special way to add the release note for both desktop and Android?

I see our release note on 89.0a1's Desktop Nightly release notes, but I don't see a page for Android Nightly's release notes:

https://www.mozilla.org/en-US/firefox/89.0a1/releasenotes/

btw, the Android Beta release notes are from the ancient Fennec 68.7beta and should probably be taken down:

https://www.mozilla.org/en-US/firefox/android/68.7beta/releasenotes/

Flags: needinfo?(pascalc)

(In reply to Chris Peterson [:cpeterson] from comment #14)

Pascal, the non-native theme is also relevant for Android's release notes for 89.0a1. Do I need to flag this bug in a special way to add the release note for both desktop and Android?

I see our release note on 89.0a1's Desktop Nightly release notes, but I don't see a page for Android Nightly's release notes:

https://www.mozilla.org/en-US/firefox/89.0a1/releasenotes/

btw, the Android Beta release notes are from the ancient Fennec 68.7beta and should probably be taken down:

https://www.mozilla.org/en-US/firefox/android/68.7beta/releasenotes/

I am not sure who owns Android release notes these days, I'll investigate.

Flags: needinfo?(pascalc)
You need to log in before you can comment on or make changes to this bug.