Closed Bug 1697801 Opened 9 months ago Closed 9 months ago

Search bar text pushes other elements down in Compact mode

Categories

(Firefox :: Address Bar, defect, P1)

Firefox 88
defect
Points:
2

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- unaffected
firefox88 --- fixed

People

(Reporter: Fanolian+BMO, Assigned: mak)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: nightly-community, regression, reproducible, Whiteboard: [proton-address-bar])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0
Build ID: 20210311093001

Steps to reproduce

  1. Use a new profile. No proton related stuff is enabled.
  2. Set UI density to Compact.
  3. Add search bar to the toolbar.
  4. Type something in search bar.

Actual result

When there is text in the bar:

  1. Search bar is stretched to the bottom for 1px.
  2. Content window is pushed down for 1px.
  3. Some other text elements are also pushed down.

Please refer to the attached video.

Notes

  1. Normal and Touch density are not affected.
  2. Typing in address bar does not exhibit the issue.

This is regressed by bug 1696628. Bug 1697293 does not fix it.

Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1696228
Regressed by: 1696628
No longer regressed by: 1696228

Blocking proton project because it was caused by related work.

Assignee: nobody → mak
Status: UNCONFIRMED → ASSIGNED
Points: --- → 2
Ever confirmed: true
Whiteboard: [proton-address-bar]
Severity: -- → S3
Priority: -- → P1

I cannot reproduce off-hand, so there must be some option involved.
What's your Windows dpi setting, did you increase the text size? You can find those options under Screen in Windows Settings.

Flags: needinfo?(Fanolian+BMO)

I find 2 cases that cause the search box to expand.

Common spec:
Windows 10 20H2 19042.867 (the current latest release)
23" 1920 × 1080 monitor

I alter the font size at Ease of Access: Start > Settings > Ease of Access > Display > Make text bigger. Display scaling can be altered here too (Make everything bigger). Note that here it affects the main display (monitor 1) only.

Case 1:
Scaling = 100% AND text size ≦ 133%
Result: see comment 0.

Case 2:
Scaling = 125% AND text size ≦ 141%
Result: at Normal density, search box is expanded upwards instead. Unlike case 1, no other Nightly elements are affected as far as I can see; Compact density is not affected at any font size at this scale.

Notes:
Few years ago I followed another guide to increase font sizes through registry for some Windows elements. I should have reset the size to default after major Windows update and I now change font size only from Ease of Access. This should not affect my testing.

Flags: needinfo?(Fanolian+BMO) → needinfo?(mak)

It must be a pixel rounding problem, I'll test with the settings you suggested.

Flags: needinfo?(mak)

So, I cannot reproduce the bug yet, I tried various resolutions spanning from 1920x1080 to 3440x1440, dpi from 100% to 225%, and text size from 100% to 141%.
But I think in the end the problem is the "half pixel hack" i put in to workaround a strange alignment issue, for which the icons background was not touching the field border. I think I found a better solution now that should also solve this.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/9c4b24df327f
Remove half pixel hack and not necessary alignment from page actions. r=harry
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Please let me know if this solved the problem when next Nightly will be available.

Flags: needinfo?(Fanolian+BMO)

(In reply to Marco Bonardo [:mak] from comment #9)

Please let me know if this solved the problem when next Nightly will be available.

Fixed in 20210315214853. Thank you.

Status: RESOLVED → VERIFIED
Flags: needinfo?(Fanolian+BMO) → needinfo?(mak)

thanks for verifying the fix.

Flags: needinfo?(mak)
Regressions: 1698834
You need to log in before you can comment on or make changes to this bug.