Closed Bug 1698436 Opened 9 months ago Closed 9 months ago

Proton customization - re-center several buttons inside the overflow dropdown menu

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: cfogel, Assigned: mhowell)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [proton-toolbar])

Attachments

(2 files)

Attached image Untitled-2.png

Affected versions

  • 88.0a1 (2021-03-14)

Affected platforms

  • Win10, macOS 10.13;

Steps to reproduce

  • pref set to true: browser.proton.enabled
  • pref set to true: browser.proton.toolbar.enabled
  1. Launch Firefox, access the Customize browser page;
  2. Drag all the available buttons in the Overflow menu;

Expected result

  • button icons have the same offset from the left-side of panel;

Actual result

  • button icons are no longer centered for:
    • Reload;
    • Profiler;
    • Cut / Copy / Paste;

Regression range

  • visible with proton-toolbar changes;

Additional notes

  • set as S3 for now, since this might still be worked on;
  • attached screenshot to better illustrate the issue.
Summary: Proton customization - re-center several buttons inside the ovreflow dropdown menu → Proton customization - re-center several buttons inside the overflow dropdown menu
Priority: -- → P2

Marking as P1. Per experience review we agreed to mark as P1 bug the ones that will block MR1.

Priority: P2 → P1
Has STR: --- → yes
Duplicate of this bug: 1699377

Gonna give this one a shot, if nobody else is working on it.

Assignee: nobody → mhowell
Status: NEW → ASSIGNED

This also fixes an issue with block margins that I noticed while developing
this patch, namely that the Profiler menu item was a few pixels too short
in addition to being offset to the right.

Duplicate of this bug: 1698377
See Also: → 1700469
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9ba9e2a13535
Keep overflow/customize menu items aligned. r=desktop-theme-reviewers,harry
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

I managed to reproduce the issue on an older version of Nightly using Windows 10 x64.
I retested everything using latest Nightly 89.0a1 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13.. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Regressions: 1702187
You need to log in before you can comment on or make changes to this bug.