Closed Bug 1698846 Opened 6 months ago Closed 6 months ago

[Proton] The popup disappears immediately when Click Library button -> click ">" Mark to show Bookmarks sub-view

Categories

(Core :: Graphics: WebRender, defect)

Firefox 88
Desktop
Windows 10
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: alice0775, Unassigned, NeedInfo)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Reproducible: almost 50%

Steps to reproduce:

  1. Enable Proton.

  2. Disabled Windows10 Animation. set ui.prefersReducedMotion=1

  3. Enough number of recent bookmarks(more than 100).

  4. Enable Bookmarks toolbar

  5. Show Other Bookmarks button at the right side of Bookmarks toolbar

  6. Bookmarks toolbar is overflowed (i.e. ">>" mark display)

  7. Put the Library button[|||\] so that it is directly above the chevron [>>]

  8. Click the Library button

  9. Click ">" Mark to show Bookmarks sub-view

  10. If not reproduce, Repeat from step.8

Actual results:
The popup disappears immediately.

Expected Results:
The popup should not disappear.

I think it is due to the same cause as bug 1698375.

Depends on: 1698375
Keywords: regression
Summary: The popup disappears immediately when Click Library button -> click ">" Mark to show Bookmarks sub-view → [Proton] The popup disappears immediately when Click Library button -> click ">" Mark to show Bookmarks sub-view
Component: Bookmarks & History → Toolbars and Toolbar Customization
Product: Firefox → Toolkit

The problem occurs without bookmarks toolbar....

Has Regression Range: --- → yes
Has STR: --- → yes
No longer depends on: 1698375
Regressed by: 1697040

Screencast: https://www.youtube.com/watch?v=LnFn4cbnvMU
The bug appear at 00:05- and 00:15-

Set release status flags based on info from the regressing bug 1697040

:aosmond, could you take a look?

Component: Toolbars and Toolbar Customization → Graphics: WebRender
Flags: needinfo?(aosmond)
Product: Toolkit → Core

Alice, does this still occur on latest nightly? It seems like it could be a dup of bug 1698067.

Flags: needinfo?(alice0775)

(In reply to Jamie Nicol [:jnicol] from comment #7)

Alice, does this still occur on latest nightly? It seems like it could be a dup of bug 1698067.

I can still reproduce the issue on Nightly88.0a1(20210319095339).
However, It is very rare. .... I can close this bug.

I found STR:

  1. Click Library button
  2. Click first [>] button and then quickly move mouse pointer to the Library button
Flags: needinfo?(alice0775)
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
See Also: → 1700101
You need to log in before you can comment on or make changes to this bug.