Closed Bug 1700101 Opened 6 months ago Closed 6 months ago

The Library panel is broken when accessing the History option

Categories

(Core :: Graphics: WebRender, defect, P1)

Firefox 89
All
Windows
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- unaffected
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: ciprian_georgiu, Assigned: mconley)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression, Whiteboard: [proton-door-hangers])

Attachments

(2 files)

Attached image LibraryMenu.gif

Affected versions

  • latest Nightly 88.0a1

Preconditions

  • Have around 30 sites populated in History.
  • Library icon (from Customize page) is dragged & dropped into toolbar.

Affected platforms

  • Windows 10 x64

Steps to reproduce

  1. Click on the Library icon from the toolbar.
  2. Click on the History option.
  3. Rapidly close the panel via "<" button from the sub panel.
  4. Repeat steps 2 and 3, if the issue is not reproduced instantly.

Expected result

  • The Library panel is correctly displayed.

Actual result

  • The Library panel is broken.

Suggested Severity

  • S2, since this is a regression.

Regression range

Additional notes

  • it seems that this issue is Windows specific. I cannot reproduce it on Ubuntu nor macOS.
  • please see the attached screencast.
  • I can also reproduce this with browser.proton.enabled set to false.
Has Regression Range: --- → yes
Has STR: --- → yes

This was filed today, and though very similar to bug 1698846 the conversation at https://bugzilla.mozilla.org/show_bug.cgi?id=1698846#c7 is from 3 days ago, so I assume this is not yet fixed... Jamie, can you take a look or forward to the right person?

Component: Menus → Graphics: WebRender
Flags: needinfo?(jnicol)
Product: Firefox → Core
See Also: → 1698846

Here's another one Andrew :)

Flags: needinfo?(jnicol) → needinfo?(aosmond)

I can reproduce this with/without proton on Windows10. And this is more reproducible than bug 1698846.

Bug 1700153 will resolve this issue for Beta88.

I tried on a new profile without the proton flags using the latest Nightly and am not able to reproduce while I can reproduce fairly easily with the proton flags on. Windows 10.

Duplicate of this bug: 1701342
See Also: → 1701659
Duplicate of this bug: 1701577
Duplicate of this bug: 1701440
Priority: -- → P1
Duplicate of this bug: 1701659

I have found a way to reproduce this bug 100% on Nightly89.0a1 Windows10 with/without Proton.

STR:

  1. Put Text Encoding toolbutton in Overflow Menu.
  2. Open data:text/html;Shift_JIS,Other than UTF-8:%E3%81%82<a href="https://www.google.com" style="float:right;padding-right:50px;">Go to Google</a>
  3. Click Overflow Menu button.
  4. Click Text Encoding to open sub-view.
  5. Click < button at the top-left corner of the menu

Optionally
6. Once after this bug happen, attempt to click Go to Google link.

Actual Results:
This bug appears[step.5].
Once after this bug have happened, The Overflow Menu is always broken.
And the link is not responding[step.6]

See Also: → 1703149
Whiteboard: [proton-door-hangers]
Blocks: 1700957
Duplicate of this bug: 1703149

I can reproduce this fairly easily. Investigating.

Assignee: nobody → mconley

Okay, I can't seem to reproduce this with gfx.webrender.software.unaccelerated-widget.allow set to false (which is effectively a backout of bug 1697040).

Alice0775, do you see the same behaviour? If you set gfx.webrender.software.unaccelerated-widget.allow to false and restart, can you still reproduce the bug?

Flags: needinfo?(alice0775)

Presuming this is caused by gfx.webrender.software.unaccelerated-widget.allow, this might result in a change of priority.

Tyler, I spoke to jimm about this. It seems as if this is caused by gfx.webrender.software.unaccelerated-widget.allow, which is a pref that allows the WebRender software fallback to be used for panels. This preference is enabled on EARLY_BETA_OR_EARLIER and Nightly, primarily to solve problems with Fission experiments that are running on 88 Beta and 89 Nightly.

I think the main takeaway though is that gfx.webrender.software.unaccelerated-widget.allow is not set to ride out to release in either 88 or 89. So presuming this pref is the sole cause of the glitch, then release channel users will never see it.

Given the above, and that we think only Nightly and Beta users will see this glitch, and that the Library panel itself has been de-emphasized with Proton, do we still believe this to be a P1 blocker?

Edit: it looks like gfx.webrender.software.unaccelerated-widget.allow is Nightly only for now, as of bug 1700153.

Flags: needinfo?(tduzan)

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #13)

Alice0775, do you see the same behaviour? If you set gfx.webrender.software.unaccelerated-widget.allow to false and restart, can you still reproduce the bug?

Yes, setting gfx.webrender.software.unaccelerated-widget.allow to false will fix this issue.

[Edit]
No. I can still reproduce this issue even if set the pref to false, but it is rare....

Flags: needinfo?(alice0775)

No. I can still reproduce this issue even if set the pref to false, but it is rare....

Thanks, Alice0775 - did you need to change any of your steps in order to reproduce it with the pref disabled?

Flags: needinfo?(alice0775)

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #16)

No. I can still reproduce this issue even if set the pref to false, but it is rare....

Thanks, Alice0775 - did you need to change any of your steps in order to reproduce it with the pref disabled?

I think nothing special steps.
Screencast: https://youtu.be/V-8EIxgG6s8?t=26

Flags: needinfo?(alice0775)

Thanks, Alice0775. Can you please attach your current about:support?

Flags: needinfo?(alice0775)
Attached file about:support

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #18)

Thanks, Alice0775. Can you please attach your current about:support?

Flags: needinfo?(alice0775)

Alright, I'm having no luck reproducing this, but Alice0775 can (but it's rare).

I'm going to modify what I wrote in comment 14:

We think that gfx.webrender.software.unaccelerated-widget.allow makes this problem much easier to hit, but we're able to get a similar broken state even with the pref disabled.

tduzan, I'm still unsure if this should qualify as a P1 given that:

  1. gfx.webrender.software.unaccelerated-widget.allow set to true, which makes the problem much easier to hit, is held to Nightly right now
  2. When gfx.webrender.software.unaccelerated-widget.allow is false it's possible to hit a similar issue, but it's much much more rare.

What do you think?

Blocks: 1701451
Blocks: gfx-triage

My situation is similar to Mike's, with swiggle for popups this reproduces after a few expansions of the drop down. Without swiggle I can't reproduce.

Graphics team is looking at this.

Flags: needinfo?(aosmond)
Depends on: 1703524

FWIW I could reproduce consistently and setting gfx.webrender.software.unaccelerated-widget.allow to false fixes the issue.
Is that an option to disable gfx.webrender.software.unaccelerated-widget.allow on nightly as we enable the proton pref? (concern here is getting Proton useage on a feature that has fair amount of use)

No longer depends on: 1703524

We're going to turn the popup pref off in Nightly today. Any remaining issue may be something entirely different, so a regression range on that would be helpful.

Depends on: 1703524

I have filed Bug 1703569 under gfx.webrender.software.unaccelerated-widget.allow=false.

The backout for bug 1703524 has landed, and the bug is now closed. This bug should be hard (but not impossible - see bug 1703569) to hit in the next Nightly build.

I'm going to close this out as RESOLVED FIXED. Prioritization and investigation for the rarer case should be done in bug 1703569.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Version: Firefox 88 → Firefox 89

I can confirm I can no longer reproduce the issue with Firefox 89.0a1 (20210407212527) on Windows 10x64 by following comment 0 and comment 10 steps. Tried multiple times with proton enabled and disabled and the issue is no longer occurring. Also, a quick check was performed on macOS M1 11.2.3 and Ubuntu 20. Closing this as verified.

Status: RESOLVED → VERIFIED
Flags: needinfo?(tduzan)
No longer blocks: gfx-triage
See Also: → 1704715
No longer blocks: 1701451
You need to log in before you can comment on or make changes to this bug.