<P> tag after </TR> closes table before </TABLE>

VERIFIED FIXED

Status

()

Core
HTML: Parser
P1
major
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: phillip, Assigned: rickg)

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
winnt 4.0, win 95 with ngt.exe, build 98113011

the letter from steve case should be in a small table, but it appears
at the bottom of the screen.  the navigation bar on the left column is
also thrown off. this is a highly visible page, especially to our
audience: www.mozilla.org...

Updated

20 years ago
Summary: ss:terrible layout of the latest news from mozilla.org → terrible layout of the latest news from mozilla.org

Comment 1

20 years ago
Yes, not the prettiest, but acceptable on win95 Nov 30 build. I can read the
letter ok.  Not ss: for this release.  Taking off ss: list for now.

Updated

20 years ago
Assignee: buster → rickg
Component: HTMLTables → Parser

Comment 2

20 years ago
see the handy minimized test case below.  Note the <P> tags after </TR> in the
nested table.  These cause closure on the table when they shouldn't.

=================== TEST CASE  ======================

<HTML>
<BODY BGCOLOR="#FFFFFF" TEXT="#000000" LINK="#0000EE" VLINK="#551A8B"
ALINK="#FF0000" MARGINHEIGHT=0 MARGINWIDTH=0>

<TABLE BORDER=0 CELLPADDING=0 CELLSPACING=0 WIDTH="100%" bgcolor=yellow>
  <TR>
    <TD VALIGN=TOP ROWSPAN=2>
		<P><CENTER>
		<TABLE WIDTH="80%" BORDER CELLPADDING=16 CELLSPACING=0>
		  <TR>
			<TD BGCOLOR="#FEFFE6">
			  <TABLE CELLPADDING=0 CELLSPACING=0 BORDER=0>
				<TR>
					<TH VALIGN=BASELINE ALIGN=RIGHT>From:
</TH>
					<TD>Steve Case &lt;...&gt;</TD>
				</TR>
				<P>
				<TR>
					<TH VALIGN=BASELINE ALIGN=RIGHT>To:
</TH>
					<TD>Jamie Zawinski &lt;<A
HREF="mailto:jwz@mozilla.org">jwz@mozilla.org</A>&gt;</TD>
				</TR>
				<P>
				<TR>
					<TH VALIGN=BASELINE ALIGN=RIGHT>Date:
</TH>
					<TD>Wed, 25 Nov 1998 12:10:18 EST</TD>
				</TR>
				<P>
				<TR>
					<TH VALIGN=BASELINE ALIGN=RIGHT>Subject:
</TH>
					<TD>Mozilla</TD>
				</TR>
				<P>
			  </TABLE>

			  <P>Jamie,
			</TD>
		  </TR>
		</TABLE>
    </TD>
  </TR>
</TABLE>
</BODY></HTML>
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

20 years ago
Duplicate "bad content in table" bug.

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
*** This bug has been marked as a duplicate of 1474 ***

Comment 5

20 years ago
*** Bug 2079 has been marked as a duplicate of this bug. ***

Comment 6

20 years ago
I marked #2079 as a dup of #1699 and here are my comments from there.

  NOTE: bug #1699 is *NOT* a duplicate of #1474 -- please read the section
  in #1474 from phillip@netscape.com  (11/30/98 11:45) and try the test case
  there -- it's not the same thing as this bug.

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
This is a dup of #1699 -- aka 'bad content in table' -- there are <P>s in
between the <TR>s, and they close out the table wrongly.

I have posted a "fixed" version of stevecase.html at

   http://qsilver.queensu.ca/~buslib/stevecase

with a 'diff -c' of how to workaround the problem.

However, (I note), in the comments of #1699, bug #1699 has been marked as a
duplicate of #1474:

This is *not* correct -- look at the test case earlier in the bug report of
#1474 -- it is an instance of the <table width="nn%"> bug -- (n.b. there are a
lot of duplicates of this bug in the db)

The 'bad content in table' and 'table width="nn%"' are *distinct* (although, by
their nature, they often travel together in pages with deeply nested tables,
and can be confused with each other).

The 'dup' of 1699-1474 should be backed-out of the database.

Cheers .. John

Updated

20 years ago
Status: VERIFIED → REOPENED
Summary: terrible layout of the latest news from mozilla.org → <P> tag after </TR> closes table before </TABLE>

Comment 7

20 years ago
Reopening bug since it is not a dup of 1474. Changing summary to reflect nature
of bug more clearly.

Updated

20 years ago
Resolution: DUPLICATE → ---

Comment 8

20 years ago
*** Bug 2113 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Updated

20 years ago
Status: RESOLVED → REOPENED

Updated

20 years ago
Resolution: FIXED → ---

Comment 9

20 years ago
Reopening bug since not a dup, but still legitimate.  phillip, could you check
this with latest build please.
(Reporter)

Comment 10

20 years ago
as of the build on friday, 08.jan.1999, it's still as broken as ever on windows.
i'm in the process of checking with linux...
(Reporter)

Comment 11

20 years ago
same story for RedHat 5.2 linux...

Comment 12

20 years ago
phillip, if this is on Mac too, please change Platform to All.
(Reporter)

Updated

20 years ago
Hardware: PC → All
(Reporter)

Comment 13

20 years ago
verily this happens on my favourite imac too. (at least we have platform parity
on this one...). changing to Platform::All

Comment 14

20 years ago
Check this on a post Jan 8th build. I believe that the changes checked in Friday
night by rickg@netscape.com were explicitly to address this kind of problem.

This page is OK for the 'nightly Jan 12th win95 build'.

(Or to be more exact, it is OK *if* you ignore the redundant horizontal
scrollbar but that is already covered by several other bug reports and
this particular report was direct at the 'bad content in tables' type of bug).

Comment 15

20 years ago
phillip, what build were you on?  Was it the latest?  Try the 01/11 or 01/12
build and let us know the results against each platform.  Thanks!
(Reporter)

Comment 16

20 years ago
Sorry if my last 3 comments were unclear. they all applied to the 08.jan.1999
build. i tried it again on NT, MacOS, and Linux, and the table is correctly laid
(lain?) out. Linux is harder to verify because it only loads the first page you
try. (and then only 640x350 pixels. i'm looking into that.)

So this is officially fixed, as far as i'm concerned. (but i'm afraid to mark it
as such...)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Comment 17

20 years ago
phillip, I am going to mark this as Resolved/Fixed, you to please mark as
verfied.  If you have a slightly different new bug with Linux, please write a
new bug.  If you see this original bug occur in future bugs, please write a new
bug.
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

20 years ago
verified as of build 99011312 on NT, RedHat 5.2, and MacOS 8.5
You need to log in before you can comment on or make changes to this bug.