Closed Bug 1699676 Opened 2 years ago Closed 1 year ago

Browser Toolbox does not update breakpoints correctly if the browser console was opened first

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: ochameau)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [fixed by bug 1735825])

STR

  1. Start latest nightly (I'm on Mac)
  2. Visit any page
  3. Open the Browser Console.
  4. Open the Browser Toolbox
  5. In the toolbox navigate to content/tabbrowser.js and find reloadTab function.
  6. In the browser window, right click on the tabbar on the tab for the page you visited, and select "Reload Tab"

Expected => Breakpoint is hit.
Actual => Breakpoint is not hit.

You can achieve similar effects with removing breakpoints as well.

If the browser console is opened before the toolbox, then the breakpoints activation doesn't get updated.

If you opened the browser console first, and hit the failure mode, then you can close the browser console, and toggle the breakpoint in the toolbox and it will start working again.

Re-opening the browser console does not stop the breakpoints working - unless you also reopen the toolbox.

Flags: needinfo?(poirot.alex)
Flags: needinfo?(jdescottes)

Just a quick update to say that I still reproduce the issue on latest central today. Investigating.

No progress made on this, moving back to triage

Flags: needinfo?(poirot.alex)
Flags: needinfo?(jdescottes)

Just to note, this still bites me quite regularly. I'm happy to provide console logs or other information to help try and resolve this.

Bomsy will take a look

Severity: -- → S3
Flags: needinfo?(hmanilla)
Priority: -- → P3

let's check if this could be caused by Bug 1725623 (probably not since it's watcherActor-based, but who knows)

See Also: → 1725623
Flags: needinfo?(hmanilla)

I could not reproduce STR from comment 0. Could this have been fixed by bug 1724909 or something else?
Or I'm missing something on the STR. You set the breakpoint on the first line of reloadTab in step 5, right?

You seem to set a breakpoint in the parent process here.
Note that in bug 1730968, we are about to fix an issue with breakpoint not removed when set in content processes.

Flags: needinfo?(standard8)

Thank you for the ping, I'd been careful about what windows I had opened, so I hadn't see that this was fixed.

I did a quick trace through and found that you actually fixed it in bug 1735825, so that's great news. I'll mark this as fixed as a result of that bug.

Assignee: nobody → poirot.alex
Status: NEW → RESOLVED
Closed: 1 year ago
Depends on: 1735825
Flags: needinfo?(standard8)
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1735825]
You need to log in before you can comment on or make changes to this bug.