Closed Bug 1700656 Opened 1 year ago Closed 1 year ago

Perma toolkit/mozapps/extensions/test/xpcshell/test_upgrade.js | test_3 - [test_3 : 285] A promise chain failed to handle a rejection: The object has been already finalized. when Gecko 89 merges to Beta on 2021-04-19

Categories

(Toolkit :: OS.File, defect)

defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 + verified

People

(Reporter: aryx, Assigned: barret)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[task 2021-03-24T12:46:46.876Z] 12:46:46     INFO -  "CONSOLE_MESSAGE: (info) 1616590005722	addons.xpi	DEBUG	Updating XPIState for {"id":"addon4@tests.mozilla.org","syncGUID":"{58e1eae0-21cf-4d0d-b289-f87d9d186071}","version":"1.0","type":"extension","loader":"compat-test","defaultLocale":{},"visible":true,"active":true,"userDisabled":false,"appDisabled":false,"embedderDisabled":false,"installDate":1616590005271,"updateDate":1616590005271,"path":"/tmp/xpc-profile-xm6EK6/appdir-addons/extensions/addon4@tests.mozilla.org.xpi","skinnable":false,"sourceURI":null,"releaseNotesURI":null,"softDisabled":false,"foreignInstall":true,"locales":[],"targetApplications":[{"id":"xpcshell@tests.mozilla.org","minVersion":"1","maxVersion":"1"}],"targetPlatforms":[],"signedState":4,"signedDate":null,"seen":true,"dependencies":[],"blocklistState":0,"blocklistURL":null,"startupData":null,"hidden":false,"installTelemetryInfo":{"source":"app-global","method":"sideload"},"recommendationState":null,"rootURI":"jar:file:///tmp/xpc-profile-xm6EK6/appdir-addons/extensions/addon4@tests.mozilla.org.xpi!/","location":"app-global"}"
[task 2021-03-24T12:46:46.876Z] 12:46:46     INFO -  "CONSOLE_MESSAGE: (info) 1616590005723	addons.xpi-utils	DEBUG	Updating add-on states"
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  "CONSOLE_MESSAGE: (info) 1616590005724	addons.xpi-utils	DEBUG	Synchronously loading the add-ons database"
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (2)
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "NotFoundError: Could not open the file at /tmp/xpc-profile-xm6EK6/startupCache/webext.sc.lz4"]
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  awaitPromise@resource://gre/modules/addons/XPIProvider.jsm:215:15
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  startup@resource://gre/modules/addons/XPIProvider.jsm:2511:25
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  callProvider@resource://gre/modules/AddonManager.jsm:230:31
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  _startProvider@resource://gre/modules/AddonManager.jsm:601:17
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  startup@resource://gre/modules/AddonManager.jsm:825:14
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  startup@resource://gre/modules/AddonManager.jsm:3525:26
[task 2021-03-24T12:46:46.877Z] 12:46:46     INFO -  observe@resource://gre/modules/addonManager.js:87:29
[task 2021-03-24T12:46:46.878Z] 12:46:46     INFO -  promiseStartupManager@resource://testing-common/AddonTestUtils.jsm:942:34
[task 2021-03-24T12:46:46.880Z] 12:46:46     INFO -  test_1@/builds/worker/workspace/build/tests/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell/test_upgrade.js:117:9
[task 2021-03-24T12:46:46.880Z] 12:46:46     INFO -  _run_next_test/<@/builds/worker/workspace/build/tests/xpcshell/head.js:1627:22
[task 2021-03-24T12:46:46.880Z] 12:46:46     INFO -  _run_next_test@/builds/worker/workspace/build/tests/xpcshell/head.js:1627:38
[task 2021-03-24T12:46:46.880Z] 12:46:46     INFO -  run@/builds/worker/workspace/build/tests/xpcshell/head.js:774:9
[task 2021-03-24T12:46:46.880Z] 12:46:46     INFO -  _do_main@/builds/worker/workspace/build/tests/xpcshell/head.js:239:6
[task 2021-03-24T12:46:46.880Z] 12:46:46     INFO -  _execute_test@/builds/worker/workspace/build/tests/xpcshell/head.js:567:5
[task 2021-03-24T12:46:46.880Z] 12:46:46     INFO -  @-e:1:1
Flags: needinfo?(brennie)
Assignee: nobody → brennie
Flags: needinfo?(brennie)
Duplicate of this bug: 1700853

Please land the patch.

Flags: needinfo?(brennie)

Sorry :aryx, I was out sick at the end of last week. Landed.

Flags: needinfo?(brennie)
Pushed by brennie@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24f718552838
Prevent multiple ExtensionParent shutdown blockers from being registered r=zombie

No need to be sorry, I just wanted to ping in case the email with the r+ fell through the cracks.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.