If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

wrong parsing of dates in ftp-listings in mozilla 1.2alpha

RESOLVED FIXED

Status

()

Core
Networking: FTP
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Roy-Magne Mo, Assigned: dougt)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: verify by 1.2b, URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020913
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020913

Seems like the parsing of dates in ftp-listing has a flawed algoritm. 

Reproducible: Always

Steps to Reproduce:
1. enter ftp://ftp.mozilla.org/
2.
3.

Actual Results:  
I'm attaching a screenshot to document the issue

Expected Results:  
correctly parsed the date
(Reporter)

Comment 1

15 years ago
Does not seem to be a locale dependant issue. 

System is Redhat 7.3 with gnome2
Summary: wrong parsing of dates in ftp-listings in mozilla 1.2alpha → wrong parsing of dates in ftp-listings in mozilla 1.2alpha
(Reporter)

Comment 2

15 years ago
Created attachment 100091 [details]
screenshot of ftp listing bug

Comment 3

15 years ago
Confirming with Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) Gecko/20020910
build 2002091014. Just looks slightly different, see attached screenshot.

Comment 4

15 years ago
Created attachment 100092 [details]
screenshot of ftp listing bug on Mac

Comment 5

15 years ago
*** Bug 170076 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
confirming with linux trunk build 20020919
this look like a regression from bug 95590 (regression between builds 2002082722
and 2002082904)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 7

15 years ago
CONFIRMED, win98, mozilla 1.2a
The dates simply don't show up for the bad entries.

Comment 8

15 years ago
+nsbeta1, allplats
Keywords: nsbeta1
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 9

15 years ago
Created attachment 100231 [details] [diff] [review]
patch v.1

ParseFTPList doesn't need to worry about y2k roll over because NSPR does this
for us.  ParseFTPList use to use libc time.

Comment 10

15 years ago
Comment on attachment 100231 [details] [diff] [review]
patch v.1

r=neeti
Attachment #100231 - Flags: review+

Comment 11

15 years ago
Comment on attachment 100231 [details] [diff] [review]
patch v.1

sr=darin
Attachment #100231 - Flags: superreview+
(Assignee)

Comment 12

15 years ago
thanks.  Fixed checked into trunk.

Checking in ParseFTPList.cpp;
/cvsroot/mozilla/netwerk/streamconv/converters/ParseFTPList.cpp,v  <-- 
ParseFTPList.cpp
new revision: 1.2; previous revision: 1.1
done
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 13

15 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020925

works for me now with today's linux and osx builds.

Updated

15 years ago
Whiteboard: verify by 1.2b
*** Bug 172043 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 172137 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.