Closed Bug 1700984 Opened 8 months ago Closed 8 months ago

[Proton] Too many separators in Page context menu

Categories

(Firefox :: Menus, defect, P2)

defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox88 --- wontfix
firefox89 --- verified

People

(Reporter: bogdan_maris, Assigned: mkohler)

References

(Blocks 2 open bugs)

Details

(Keywords: helpwanted, Whiteboard: [proton-context-menus] [priority:2a])

Attachments

(3 files)

Attached image Actual context

Affected versions

  • Firefox 88.0b2
  • Latest Nightly 89.0a1

Affected platforms

  • Windows 10 64bit
  • macOS 10.15
  • Ubuntu 18.04

Steps to reproduce

  1. Start Firefox
  2. Visit a random page
  3. Right click inside the page to have Page context menu

Expected result

  • Per spec there are only 3 separators in Page context menu:

Actual result

  • There are 5 separators in Page context menu

Regression range

  • Not a regression since this is a design change.

Additional notes

  • Not sure if there is already a bug logged for this, I for one did not saw one.

Suggested severity

  • I don't think this is of a high severity, I would mark it as S3.
Has Regression Range: --- → irrelevant
Has STR: --- → yes

Setting helpwanted; This probably just means dropping some of the separators in browser-context.inc that surround "send page to device", and then the tedious work of updating the context menu mochitests for the change in expectations.

Note that the screenshots here assume you're signed in to fxa. Without being signed in, there is a similar problem in that there are 4 separators, the excess one being between "save page as" and "select all".

Type: task → defect
Keywords: helpwanted
Priority: -- → P2
Summary: [Proton] To many separators in Page context menu → [Proton] Too many separators in Page context menu
See Also: → 1701162
Whiteboard: [proton-context-menus] → [proton-context-menus] [priority:2a]
Assignee: nobody → me
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f30d84849972
Remove excessive separators in Page context menu r=jaws
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Verified that this is fixed in latest Nightly 89.0a1 across platforms (Windows 10, macOS 11.3 and Ubuntu 18.04), the number and location of the separator matches the proposed design.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.