Closed Bug 1701138 Opened 3 months ago Closed 3 months ago

layout/reftests/bugs/572598-ref.html should set `readonly` attribute to the `<input>` element

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Starting from the fix of bug 1220696, contentReadOnly command when an <input> or <textarea> has focus toggles readonly property of it instead of toggling the HTMLEditor's readonly flag. Except native theme of GTK, <input readonly> has same visual as <input>. Therefore, this bug has not been found when I work on bug 1220696.

Now, <input> element and <textarea> element handle contentReadOnly command
as toggling readonly attribute. Therefore, the result may be different if
and only if the theme changes the style with readonly attribute.

Therefore, the test result of 572598.html has been changed in logical, but
it's not been found because only GTK's native theme has different style for
<input> and <input readonly>.

This patch just changes the reference.

Set release status flags based on info from the regressing bug 1220696

Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/3c3d0c710ff8
Make 572598-ref.html set `readonly` attribute of the `<input>` element r=smaug
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
You need to log in before you can comment on or make changes to this bug.