Closed Bug 1701912 Opened 8 months ago Closed 8 months ago

[Proton] [Light theme] The checkbox color from the "Remember this decision" string does not match Figma spec

Categories

(Firefox :: Site Permissions, defect, P2)

Desktop
Unspecified
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox87 --- disabled
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: tbabos, Assigned: emmamalysz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-door-hangers][priority:2c])

Attachments

(2 files)

Tested on:
Nightly 89.0a1

Tested Platforms:
MacOS 10.15
Windows 7

Have the following prefs enabled:
browser.proton.enabled
browser.proton.doorhangers.enabled
Light Theme

Steps to reproduce:

  1. Open https://mozilla.github.io/webrtc-landing/gum_test.html
  2. Click on the Camera or Microphone button
  3. Check the Permission Panel

Expected Results:
The checkbox should be of dark grey color, as in Figma spec: https://www.figma.com/file/FjUe6ORvXZgJvI3rPuTV33/Desktop-UI-(Mozilla-Confidential-)?node-id=4%3A1

Actual Results:
The "Remember this decision" checkbox is white

Notes:
Dark theme respects the Figma specifications.

Severity: S3 → S4
Priority: -- → P2

Is that a dupe of bug 1700141?

Judging from the bug description, Bug 1700141 is about in-content styles. Those shouldn't affect the permission prompts which are chrome code.

Assignee: nobody → emalysz
Attachment #9212682 - Attachment description: WIP: Bug 1701912, add checkbox colors to light theme → Bug 1701912, add checkbox colors to light theme
Status: NEW → ASSIGNED
Whiteboard: [proton-door-hangers] → [proton-door-hangers][priority:2c]
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4aa907ad6354
add checkbox colors to light theme r=desktop-theme-reviewers,ntim
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Verified-fixed on latest Firefox Nightly 89.0a1 (2021-04-01) (64-bit) on Windows 10 and MacOS 10.15.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.