Closed Bug 1702442 Opened 8 months ago Closed 8 months ago

[Non-Proton] Search bar's keyboard highlight is barely visible in Firefox Dark theme

Categories

(Firefox :: Theme, defect, P2)

Firefox 89
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- wontfix

People

(Reporter: Fanolian+BMO, Unassigned)

References

(Depends on 1 open bug, Regression)

Details

(Keywords: nightly-community, regression, reproducible, Whiteboard: [proton-address-bar] [priority:2b] [a11y])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0
Build ID: 20210331215444

Settings

Win10 OS theme: Light or Dark
Nightly theme: Dark

No Proton related stuff is enabled in Nightly.

Steps to reproduce

  1. Add search bar to UI.
  2. Type something in the bar.
  3. Use keyboard to highlight a search suggestion/history.

Actual result

The highlight colour is barely visible.
In the attached screenshot, in both before and after the 2nd result is highlighted by keyboard navigation while 4th by mouse hover.

Notes

  1. Nightly's Default theme is unaffected even if OS is set to dark theme.
  2. URL bar is not affected.

The bug should be first introduced by bug 1692046 when Dark and Proton Dark were separated, and went through some more iterations. Now Proton Dark replaces Dark and, iiuc, rides the train with bug 1701256, this bug will affect non-Proton users at Release 89.

Blocks: 1701256
Has Regression Range: --- → yes
Has STR: --- → yes

:Fanolian+BMO, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(Fanolian+BMO)
No longer blocks: 1701256
Depends on: proton-address-bar
Flags: needinfo?(Fanolian+BMO)
Regressed by: 1701256
Whiteboard: [proton-address-bar]

I think changing these vars should fix it:
https://searchfox.org/mozilla-central/rev/54f37fc1ac0f98b590af51e01ce82bb74179bf63/browser/themes/shared/urlbarView.inc.css#15-18
maybe to match vars like --lwt-toolbar-field-focus (which is what the urlbar uses) etc.

Set release status flags based on info from the regressing bug 1701256

Whiteboard: [proton-address-bar] → [proton-address-bar] [priority:2c] [a11y]
Whiteboard: [proton-address-bar] [priority:2c] [a11y] → [proton-address-bar] [priority:2b] [a11y]
Priority: -- → P2
Status: UNCONFIRMED → NEW
Ever confirmed: true

Considering this works correctly in Proton, and Proton is being release in 89, I think this is a wontfix.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.