Closed Bug 1702834 Opened 6 months ago Closed 6 months ago

Right to left languages support

Categories

(Thunderbird :: Message Compose Window, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 464436

People

(Reporter: sallyahaj, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:87.0) Gecko/20100101 Firefox/87.0

Steps to reproduce:

Hello there,

  • Click on Write (Create a new message)
  • Start typing on the body message (email) section.
  • In English is okay,
  • In Arabic language

Actual results:

When typing in Arabic which is a "Right to Left" language, the TB doesn't move the cursor to the right.

Expected results:

As many text editor can deal with LtR and RtL languages, I think we should see that support on TB.

I am using thunderbird 78.7.0 (64-bit) on Fedora 34 Gnome 40

(In reply to José M. Muñoz from comment #1)

Have your tried this add-on: https://addons.thunderbird.net/en-US/thunderbird/addon/bidi-mail-ui/

Yes I have, the add-on is helpful but at the same time isn't that perfect, I have to change the direction of the language by clicking the right icon,
in addition it changes the encoding of the TB to "Windows-1254", which was by default UTF-8.

Does UTF-8 support RtL languages?

I hope to see the feature in TB, not just as an add-on.
Thank you

You're not the first one to ask for this feature. The bug should be closed as a duplicate bug 464436 (also see bug 119857).

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 464436
You need to log in before you can comment on or make changes to this bug.