Closed Bug 1703178 Opened 3 years ago Closed 3 years ago

Set overrideDPPX BrowsingContext property in the parent process

Categories

(DevTools :: Responsive Design Mode, task)

task

Tracking

(Fission Milestone:M7a)

RESOLVED FIXED
Fission Milestone M7a

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission-m3-mvp)

Attachments

(1 file, 2 obsolete files)

Some ResponsiveActor methods do a bit more than setting the flag on the browsing context, so we might still keep them, and make the RDM ui use targetConfigurationCommand that will abstract calls to both parent and content processes.

Fission Milestone: --- → M8
Keywords: leave-open
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ffe826ff89b9
[devtools] Set overrideDPPX browsingContext property in the parent process. r=jdescottes,devtools-backward-compat-reviewers.
Regressions: 1703543

Here we introduce a specific method in the targetConfigurationCommand as we need
to set the flag on the parent process (in the targetConfigurationActor), but we also
need to create the TouchSimulator from the content process (via the ResponsiveActor).

The work on the setTouchEventsOverride commands seem to have changed
timing a bit and it resulted in intermittent failures on browser_touch_device.js.
The failures was about a pending SpecialPowers.spawn call while the SpecialPowers
actor is destroyed, which indicates an issue with a document closing too early.
Since the test is properly waiting for all the method that use SpecialPowers.spawn,
it seemed like the issue was because of the reload-on-touch-simulation-toggle feature,
as we don't wait anywhere in the test for the document to be loaded or anything.
As the reload-on-touch-simulation-toggle pref was enabled on this test only to be
able to use the toggleTouchSimulation helper, it's probably safe to not enable it,
and instead allow the helper to not wait for the load.
This seems enough to fix the failures I was experiencing with this patch queue.

Depends on D111262

Attachment #9214684 - Attachment is obsolete: true
Blocks: 1704729
No longer blocks: 1690100, 1704729
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: leave-open
Resolution: --- → FIXED
Summary: Set RDM-related BrowsingContext flags in parent process instead of ResponsiveActor (which lives in content process) → Set overrideDPPX BrowsingContext property in the parent process
Blocks: 1704729

Comment on attachment 9214393 [details]
Bug 1703178 - [devtools] Set touchEventsOverride browsingContext property in the parent process. r=jdescottes.

Revision D111262 was moved to bug 1704733. Setting attachment 9214393 [details] to obsolete.

Attachment #9214393 - Attachment is obsolete: true
Fission Milestone: M8 → M7a
Blocks: 1706272
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: