Closed Bug 1704280 Opened 3 months ago Closed 1 month ago

Change Default Port for Internet Relay Chat (IRC) via TLS/SSL to 6697

Categories

(SeaMonkey :: Chat, enhancement)

enhancement

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.87
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

()

Details

(Whiteboard: SM2.53.8)

Attachments

(1 file)

At the moment ChatZilla uses port 9999 for the default port for secure connections, according to RFC 7194 it should now be 6697.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: trying to securely connect to an irc server uses port 9999 instead of 6697
Testing completed (on m-c, etc.): 2.53.8
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: 1 change

Attachment #9214880 - Flags: review?(frgrahl)
Attachment #9214880 - Flags: approval-comm-release?
Attachment #9214880 - Flags: approval-comm-esr60?
Blocks: 1704392
Blocks: 1704399

Comment on attachment 9214880 [details] [diff] [review]
1704280-ircs-2538.patch

LGTM

Attachment #9214880 - Flags: review?(frgrahl)
Attachment #9214880 - Flags: review+
Attachment #9214880 - Flags: approval-comm-release?
Attachment #9214880 - Flags: approval-comm-release+
Attachment #9214880 - Flags: approval-comm-esr60?
Attachment #9214880 - Flags: approval-comm-esr60+

https://hg.mozilla.org/comm-central/rev/6e08cc29492c9bf159de2d81015dbc4c979b60b0
Change Default Port for Internet Relay Chat (IRC) via TLS/SSL to 6697. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.87
You need to log in before you can comment on or make changes to this bug.