Closed Bug 1704788 Opened 8 months ago Closed 8 months ago

[Proton] [Windows] Keyboard access key for `Open a New Tab` is in conflict with the same key attributed to a disabled label

Categories

(Firefox :: Menus, defect)

Firefox 89
Desktop
All
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- verified

People

(Reporter: bogdan_maris, Assigned: Gijs)

References

Details

(Whiteboard: [proton-context-menus])

Attachments

(1 file)

Affected versions

  • Latest Nightly 89.0a1

Affected platforms

  • Windows 10
  • Windows 7

Unaffected platforms

  • Ubuntu 18.04

Steps to reproduce

  1. Start Firefox with a new profile
  2. Right click the opened tab or in the tab bar
  3. Hit 'O' key from keyboard to open a new tab
  • Reopen closed tab option is disabled in context menu.

Expected result

  • A new Tab is opened

Actual result

  • Focus selector also jumps to Reopen closed tab (even if disabled) preventing opening a new tab.

Regression range

  • This is not a regression since it was introduced when this was first implemented in bug 1692840.

Additional notes

  • On Ubuntu this issue does not happen, even if Reopen closed tab is visible and disabled a new tab will open when hitting 'O' key.

Suggested severity

  • This is of S3 severity in my Opinion since it prevents users (in certain conditions) to use the newly added option.
Has Regression Range: --- → no
Has STR: --- → yes
Whiteboard: [proton-context-menus]
Severity: -- → S3
Severity: S3 → S2
Summary: [Proton] [Windows] Keyboard shortcut for `Open a New Tab` is in conflict with the same key attributed to a disabled label → [Proton] [Windows] Keyboard access key for `Open a New Tab` is in conflict with the same key attributed to a disabled label

Gah, should have caught this in review.

Assignee: nobody → gijskruitbosch+bugs
OS: Windows → All
Hardware: All → Desktop
Pushed by flodolo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/824840346a73
resolve duplicate access key for 'open a new tab' menuitem in the tabstrip context menu, r=flod,fluent-reviewers
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Verified that the access key for Open a New Tab is now changed to W and now I don't see any more issues with it. Verified across platforms (Windows 10, Windows 7, macOS 11.3 and Ubuntu 18.04) even though this was not an issue on Ubuntu and macOS.

Status: RESOLVED → VERIFIED

You have "Ctrl+T" for new tab button.
Why "W" in context menu?
Shouldn't it be "T" or "Ctrl+T"?

(In reply to Kazumasa Hasegawa (Kazz) from comment #6)

You have "Ctrl+T" for new tab button.
Why "W" in context menu?
Shouldn't it be "T"

When you use this context menu on an empty bit of tabstrip, we show a context menu where "T" is in use for "Bookmark selected tab". Access keys are meant to be unique within their menu, so "T" wouldn't work there.

I decided that using a consistent access key, so that we don't do something different depending on whether you just about click a tab vs just about click an empty bit of tabbar space, would be better than going for a different access key in both places.

Perhaps there is a solution that would allow the use of "T" for "New Tab" without conflicts by changing a bunch of other access keys, but it (a) wasn't obvious to me and (b) would probably get people complaining because the access key for a menuitem switched from being on the left hand side of the keyboard to being on the right hand side of the keyboard (which is what happened when I changed the access key for something in the main page context menu).

or "Ctrl+T"?

I'm not really sure what your point is - this shortcut already exists?

Shortcuts and access keys are different things and are often not the same (e.g. New Private Window and Save Page As in the File menu have access keys that don't match their shortcut letter). If you were going to use a shortcut you'd do that without opening the context menu.

Understood.
Just to point out one more thing, "W" doesn't seem to be a good access key for a menu that opens a new tab.
In our experience, "W" is associated with "Window" in many cases.
As a result, when I saw the "W" access key, it may confuse users that if a new tab would open in a new window.

You need to log in before you can comment on or make changes to this bug.