Closed Bug 1705448 Opened 8 months ago Closed 8 months ago

Save password popover/doorhanger is extremely bare looking, blends in with page

Categories

(Firefox :: Theme, defect)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- affected

People

(Reporter: yoasif, Unassigned)

References

(Regression)

Details

(Keywords: nightly-community, regression, Whiteboard: [proton-door-hangers] )

Attachments

(2 files)

Attached image image.png

Noticed today that the password popover has regressed.

The new version:

  • doesn't seem to have a default button
  • doesn't seem to have colors besides white
  • has no icon

Ultimately, this makes it blend in with pages with white backgrounds and makes it extremely hard to scan.

Interestingly, the Chromium version of this popover looks a lot better and doesn't have these issues - there are colors, it is easy to distinguish from the page, there is even an image.

Steps to reproduce:

  1. Navigate to https://senglehardt.com/demo/no_boundaries/loginmanager/index.html
  2. Type in any email and password
  3. click submit

What happens:

A worse save password popover appears.

Expected result:

Like before bug 1703716.

20:52.61 INFO: Narrowed integration regression window from [63ddc207, 44916257] (4 builds) to [0b713a5f, 44916257] (2 builds) (~1 steps left)
20:52.61 INFO: No more integration revisions, bisection finished.
20:52.61 INFO: Last good revision: 0b713a5fada84a4b8f3e79e10e3b213064c0690e
20:52.61 INFO: First bad revision: 44916257e3052502b8d9465b73be4d5a8c4919e7
20:52.61 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0b713a5fada84a4b8f3e79e10e3b213064c0690e&tochange=44916257e3052502b8d9465b73be4d5a8c4919e7

Attached image chromium-better
Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1703716
Summary: Save password popover is extremely bare looking, blends in with page → Save password popover/doorhanger is extremely bare looking, blends in with page

Set release status flags based on info from the regressing bug 1703716

Can you help triage for priority?

Flags: needinfo?(dao+bmo)
Whiteboard: [proton-door-hangers]

I think this is by design, but cc'ing KatieC just in case she wants to have another look.

Yes, this is by design - all permissions panels are updated for the 89 release.
• No primary default button / keep neutral, secondary buttons for use choice for site permissions
• Colour of panel reflects the theme (light, dark, custom)
• Limited use of icons in panels (and in the Core UI in general) - key icon is in Address bar as anchor for panel.

Okay, closing this out as INVALID then. Thanks, KatieC.

Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(dao+bmo)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.