[DOGFOOD] [PP] mac: POP mail filtering on body doesn't work

VERIFIED FIXED in M13

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: ekrock, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
As of M10 this is not yet implemented on any platform.

I'm nominating this as a [DOGFOOD] bug because I personally have 181 filters
defined including many with tests on the POP3 message body, and I can't move
over to Nav5 Messenger until this is supported.  (If I had to sort all that
email manually, my work would grind to a halt.  Over the last 3 years I've
created many email submission links and mail submit forms across DevEdge Online
for developer input and I rely on mail filtering with body tests to manage the
flow.)

I should mention that this feature was on the post beta 1 list.  I know
we're trying to avoid feature creep for beta 1, but this is a genuine dogfood
issue at least for me, so I'll let PDT make the call on that issue.

Sorry if this is a DUP, but I queried and couldn't find a bug specifically for
mail filtering on the body, although there were references in other descriptions
to the fact that it's not yet implemented.

Updated

19 years ago
QA Contact: lchiang → laurel

Updated

19 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 1

19 years ago
Eric, have you migrated your profile from 4.x? In general, migrated filters are
supposed to work, even though we don't yet have a front-end for manipulating
filters in mozilla. I would also be unhappy if I had no filters at all, but I'm
limping along with migrated filters.

Comment 2

19 years ago
Doesn't work with migrated filters. Basic Sender & subject do, but this doesn't
(there is a problem with filtering date, too, already logged against bienvenu).

Updated

19 years ago
Whiteboard: [PDT-]

Comment 3

19 years ago
We think this is an edge case, and are impressed with the amount of mail you
must read.  Please provide 5 more names and we'll go with a PDT+.

Updated

19 years ago
Assignee: phil → bienvenu

Comment 4

19 years ago
David, I saw you were working on this, so over to you.
(Assignee)

Comment 5

19 years ago
*** Bug 17173 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
I didn't know this bug existed, so I filed a new one a few days ago, but I
ported over the code last night while I was blocked on something else. It almost
works now. Not quite, though.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
this basically works now. I've seen some strange problems where sometimes
filters don't fire when you have multiple matching messages, but I can't
reproduce it. If that doesn't put blood in the water, I don't know what will :-)

Comment 8

19 years ago
Basics working on NT 4.0 using 1999-11-04-08m11 commercial build.
Am definitely seeing the multiple message match problem David described above --
will log a separate bug on that.

Still verifying other platforms...

Updated

19 years ago
Status: RESOLVED → REOPENED
Summary: [DOGFOOD] POP mail filtering on body doesn't work → [DOGFOOD] [PP] mac: POP mail filtering on body doesn't work

Updated

19 years ago
Resolution: FIXED → ---

Comment 9

19 years ago
Basics work for single match message using nov5 commercial build on linux 6.0

I cannot get (POP) body filter to work on Mac using nov5 commercial build. (can
get other filter like simple subject contains to work on mac, so it's not that
all filters are broken on mac)

Reopening for mac case...
(Assignee)

Updated

19 years ago
Target Milestone: M12
(Assignee)

Comment 10

19 years ago
Moving to m12. Looks like I have another date with my imac :-(
(Assignee)

Comment 11

19 years ago
I think I have a fix for this but I need a green tree.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

19 years ago
Can you try this with tomorrow's build, laurel? dougt fixed a problem with file
streams, and I fixed a problem with move filters in general.

Comment 13

19 years ago
Laurel's been out sick :-(
Hopefully, she'll be in tomorrow.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 14

19 years ago
Using 12-06-08 m12 on mac OS 8.5.1 I still cannot get this to work. I've tried
many times now and have tried using body contains, doesn't contain, is, isn't.

Updated

19 years ago
Resolution: FIXED → ---
(Assignee)

Updated

19 years ago
Target Milestone: M12 → M13
(Assignee)

Comment 15

19 years ago
sor

Comment 16

19 years ago
What does your comment mean? (Are you "sor" at me for reopening? just kidding)
(Assignee)

Comment 17

19 years ago
ah, focus must have got set to the wrong window - I never meant to add a comment
to this - I was replying to a mail message which started: "sorry".
(Assignee)

Comment 18

19 years ago
OK, I found another fix - I'll try it on the mac tomorrow.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

19 years ago
OK, I got this working on my mac, anyway :-)

Comment 20

19 years ago
Did this get in for m12 or will this be checked in m13?
(Assignee)

Comment 21

19 years ago
it should be in m12, I checked it in last night.

Comment 22

19 years ago
Cannot get it to work on my machine using the 12-08-08m12 commercial build on
mac 0S 8.5.1.

Will attack it again tomorrow and also on another machine...

Is this a torture test?
(Assignee)

Comment 23

19 years ago
the filter I got to work is "body contains". I'm pretty sure I checked it in
though I could have made a boo-boo, since I make the same change on windows and
checked that in.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 24

19 years ago
Victory! This makes my day!

OK (woohoo!!) using 12-10-08m12 commercial build on Mac OS 8.5.1

Also still OK on NT 4.0 and linux using 12-10-08m12 commercial builds.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.