Closed Bug 1706408 Opened 9 months ago Closed 9 months ago

Linux Startup Crash in [@ mozilla::detail::MutexImpl::~MutexImpl | __run_exit_handlers]

Categories

(Core :: Widget: Gtk, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1706452
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- unaffected
firefox90 + fixed

People

(Reporter: aryx, Unassigned)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Regression from bug 1377445?

Crash report: https://crash-stats.mozilla.org/report/index/471cd379-d003-49bd-98c2-8c80f0210420

MOZ_CRASH Reason: MOZ_CRASH(mozilla::detail::MutexImpl::~MutexImpl: pthread_mutex_destroy failed)

Top 10 frames of crashing thread:

0 firefox-bin mozilla::detail::MutexImpl::~MutexImpl mozglue/misc/Mutex_posix.cpp:90
1 libc.so.6 __run_exit_handlers 
2 libc.so.6 __GI_exit 
3 libgtk-3.so.0 libgtk-3.so.0@0x1dcc4a 
4 libxul.so gfxPlatformGtk::gfxPlatformGtk gfx/thebes/gfxPlatformGtk.cpp:96
5 libxul.so gfxPlatform::Init gfx/thebes/gfxPlatform.cpp:912
6 libxul.so gfxPlatform::GetPlatform gfx/thebes/gfxPlatform.cpp:480
7 libxul.so mozilla::widget::GfxInfoBase::GetContentBackend widget/GfxInfoBase.cpp:1781
8 libxul.so NS_InvokeByIndex 
9 libxul.so XPCWrappedNative::CallMethod js/xpconnect/src/XPCWrappedNative.cpp:1142
Flags: needinfo?(mh+mozilla)

Could the persons CCed to this bug because they themselves filed a bug please test if this push is affected and this one works as expected? Click at the bottom on "Artifacts" and download the target.tar.bz2. Thank you in advance.

Crash Signature: [@ mozilla::detail::MutexImpl::~MutexImpl | __run_exit_handlers] → [@ mozilla::detail::MutexImpl::~MutexImpl | __run_exit_handlers] [@ bp-ad54f33f-671f-4b31-8e3a-8ac9f0210420]

This may or may not be the same thing as bug 1706452, but I can't reproduce this crash, so for now I'll assume this might be different, but we'll see if the fix there works here too, in which case we'll dupe the bugs.

Crash Signature: [@ mozilla::detail::MutexImpl::~MutexImpl | __run_exit_handlers] [@ bp-ad54f33f-671f-4b31-8e3a-8ac9f0210420] → [@ mozilla::detail::MutexImpl::~MutexImpl | __run_exit_handlers] [@ bp-ad54f33f-671f-4b31-8e3a-8ac9f0210420]
Flags: needinfo?(mh+mozilla)

I see a similar crash when running Firefox mochitest/reftest suite locally. It's a crash at gtk_init() and it generally means we can't open GdkDisplay. More details should be on terminal, may be "too many connections" or so.

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #3)

Could the persons CCed to this bug because they themselves filed a bug please test if this push is affected and this one works as expected? Click at the bottom on "Artifacts" and download the target.tar.bz2. Thank you in advance.

this one fails and this one works

Regressed by: 1377445

No crashes on Nightly since bug 1706452 landed.

Let's call this a duplicate then. :)

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1706452
You need to log in before you can comment on or make changes to this bug.