Closed Bug 1706496 Opened 2 months ago Closed 2 months ago

Menulists in preferences inaccessible with HCM

Categories

(Firefox :: Disability Access, defect)

defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 + verified
firefox89 --- verified
firefox90 --- verified

People

(Reporter: morgan, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

STR:

  1. Navigate to about:preferences and open the colors dialog by selecting 'colors' in the language and appearance section
  2. In the dialog, set the text color to white and the background color to black. The other colors are irrelevant for this example
  3. In the menulist, select 'always' and hit OK
  4. Re-open the dialog and click the same menulist

Expected: the menuitems are readable
Actual: the entire menupopup is black and the items are not readable

I ran mozregression on this, tagging the regression bug in desc

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

Otherwise the menupopup retains the native "Menu" color, which inherits
to menuitems, and can cause contrast issues for HCM users.

It also makes more sense to specify color along with background anyways.

Specifying a system color foreground with a non-system-color background
is not good.

(In reply to Morgan Reschenberg [:morgan] from comment #0)

I ran mozregression on this, tagging the regression bug in desc

The regressing bug is still open and doesn't list any commits. Can you share the regression window? Perhaps a commit used the wrong bug number? I'm also thinking perhaps I broke this in bug 1705133? It would be useful to know which release trains are affected either way, so we know where to uplift fixes, and if this is MR1-related or not. :-)

Flags: needinfo?(mreschenberg)

The regressing bug is bug 1698272, which started respecting system colors in HCM as per spec (and to fix the relevant bug).

Flags: needinfo?(mreschenberg)
Regressed by: 1698272
No longer regressed by: 1593737
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/593396efa938
Specify background along with color for menupopups. r=desktop-theme-reviewers,dao
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a016a1cc626e
Fix proton checkbox styles for HCM. r=Gijs
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Set release status flags based on info from the regressing bug 1698272

The patch landed in nightly and beta is affected.
:emilio, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

Comment on attachment 9217344 [details]
Bug 1706496 - Specify background along with color for menupopups. r=Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: High contrast mode issues.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple CSS fixes.
  • String changes made/needed: none
Flags: needinfo?(emilio)
Attachment #9217344 - Flags: approval-mozilla-beta?
Attachment #9217345 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

It seems this bug introduced a more severe regression with bug 1707384. Can we please make sure this bug does not regress dark mode per STR on https://bugzilla.mozilla.org/show_bug.cgi?id=1707384#c0 prior to uplifting?

Regressions: 1707384

Hello,

I have partially reproduced the issue using STR from comm 0, on an affected Nightly build 2021-04-20:

  • on Windows 10x64 the menuitems from the menulist are readable, but there is still a problem with the empty checkboxes.
  • on Ubuntu 20.04 the menuitems from the menulist are readable but they are grayed out (they can still be selected). The problem with the
    empty checkboxes remains.

On the lastest Nightly 90.0a1 (2021-04-26) the issue is not reproducible. Tests were performed on Windows 10x64, Ubuntu 20.04, macOS 11.0.1.

Comment on attachment 9217344 [details]
Bug 1706496 - Specify background along with color for menupopups. r=Gijs

Approved for 89 beta 6, thanks.

Attachment #9217344 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9217345 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9217344 [details]
Bug 1706496 - Specify background along with color for menupopups. r=Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: Invisible menulist for high-contrast users.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0. Some other sanity-checking of other menulists in non-hcm would be appreciated as well.
  • List of other uplifts needed: none (note that regression is proton-specific)
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Relatively simple CSS fix.
  • String changes made/needed: none
Attachment #9217344 - Flags: approval-mozilla-release?

I've verified the fix on 89.0b6. The testing was performed on Windows 10x64, Ubuntu 20.04 and macOS 11.0.1. Thanks!

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9217344 [details]
Bug 1706496 - Specify background along with color for menupopups. r=Gijs

Fixes a pretty severe regression for HCM users. Approved for 88.0.1.

Attachment #9217344 - Flags: approval-mozilla-release? → approval-mozilla-release+

I've verified the fix on 88.0.1. The testing was performed on Windows 10x64, Ubuntu 20.04 and macOS 11.0.1. Thanks!

You need to log in before you can comment on or make changes to this bug.