Closed Bug 1707190 Opened 7 months ago Closed 7 months ago

The Warning badge for an "Extension requires new permissions" notification from the Hamburger menu icon is misaligned

Categories

(Firefox :: Toolbars and Customization, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox88 --- disabled
firefox89 --- wontfix
firefox90 --- verified

People

(Reporter: rares.doghi, Assigned: emmamalysz)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-icons] [proton-appmenu-notifications] [priority:2a])

Attachments

(3 files)

[Affected platforms]:
Platforms: All

[Steps to reproduce]

  1. Launch the Firefox browser and install a few older addons like :
    Install version 1.35.2 of Bitwarden – Free Password manager - https://addons.mozilla.org/en-US/firefox/addon/bitwarden-password-manager/versions/?utm_content=search&utm_medium=referral&utm_source=addons.mozilla.org
    install version 7.0.0 of New Tab Override - https://addons.mozilla.org/en-US/firefox/addon/new-tab-override/versions/?utm_content=recommended_fallback&utm_medium=referral&utm_source=addons.mozilla.org

  2. Set the extensions.update.interval - 10

  3. Restart the Browser and wait for the Menu notifications to be displayed.

[Expected result]
The Warning Badge should be on top of the Hamburger menu icon (3 lines).

[Actual result]
The Warning badge is to the Right of the 3 lines (Hamburger menu) instead of on top of them (part of the top right corner).

Whiteboard: [proton-icons]
Whiteboard: [proton-icons] → [proton-icons] [proton-appmenu-notifications]
Priority: -- → P2
Whiteboard: [proton-icons] [proton-appmenu-notifications] → [proton-icons] [proton-appmenu-notifications] [priority:2a]
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4d24540ca38d
update warning and notification icons for app menu badges r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

So even though the new icon is displayed, this particular case for the extension requires new permissions case the icon from the badge is still misaligned, its all the way to the right. Ill attach a new screenshot for it.

Flags: needinfo?(emalysz)
Attached image Missaligned.png

Hey Rares, thanks for reporting. Which platform are you on? I was having trouble reproducing on macos.

I also noticed the fxa-needs-authentication still uses the full app menu icon. I can file a follow up. I think what we'll need to do to improve this is:

  1. Add #PanelUI-menu-button[badge-status="addon-alert"] > .toolbarbutton-badge-stack > .toolbarbutton-badge to this list: https://searchfox.org/mozilla-central/rev/6b099d836c882bc155d2ef285e0ad0ab9f5038f6/browser/themes/shared/customizableui/panelUI.inc.css#117

  2. Add fxa-needs-authentication to here https://searchfox.org/mozilla-central/rev/6b099d836c882bc155d2ef285e0ad0ab9f5038f6/browser/themes/shared/toolbarbutton-icons.inc.css#281

Flags: needinfo?(emalysz) → needinfo?(rares.doghi)

Hi Emma, it seems this issue only occurs on Windows and Ubuntu. Mac looks great.

Flags: needinfo?(rares.doghi)

Hi Emma.. I just got what you meant by the FxA addon=alert issue for when the user is disconnected , the badge from the FxA icon is still the Warning sign with the exclamation mark inside, did you log any follow up issue for it ? or should I log one now ?

Flags: needinfo?(emalysz)

Also, should we log a new issue for Windows and Ubuntu ? or should we reopen this one ?

Regressions: 1711083
See Also: → 1711085

Filed both as separate issues. Thanks again for reporting!

Flags: needinfo?(emalysz)

Since this fix remained for Mac only I will update the flags to Verified since this issue no longer occurs on Mac in our latest Nightly builds.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.