Closed Bug 1707603 Opened 2 months ago Closed 27 days ago

Viewing crash reports causes increasing numbers of Back operations to get back to the list

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M8
Tracking Status
firefox88 --- disabled
firefox89 --- disabled
firefox90 --- affected

People

(Reporter: jesup, Assigned: peterv)

References

Details

If I view crash reports, it takes an increasing number of clicks to get back to the about:crashes list. On the first report, it takes one click. After viewing the second report, it takes 2, on the third three, ad nausuem.

The dropdown for Back does not show any extra entries.

100% repeatable.

PeterV indicates this reproduces for him if he turned the bfcache-in-parent code off

Jesup says he could not reproduce in a March 26 build, but he can reproduce in an April 26 build. So we have a possible regression range.

needinfo'ing Jesup to bisect the regression range.

I can reproduce in my regular profile but not in a clean profile (even with fission.autostart and fission.bfcacheInParent enabled).

Fission Milestone: --- → ?
Flags: needinfo?(rjesup)

(In reply to Chris Peterson [:cpeterson] from comment #2)

I can reproduce in my regular profile but not in a clean profile (even with fission.autostart and fission.bfcacheInParent enabled).

I tried bisecting this bug, but I don't think this is a (recent) regression. I can reproduce this bug using my regular profile as far back as 86 Nightly build 2021-01-16.

Assigning to Peter.

Nika suspects this bug is related to incorrect history indexes in the content process.

kmag suspects this bug might be related to or a duplicate of moz-extension: bug 1705872.

Assignee: nobody → peterv
Severity: -- → S3
Fission Milestone: ? → M8
Flags: needinfo?(rjesup)
Priority: -- → P3
See Also: → 1705872

Randell confirmed that in 5/14 and 5/17 builds, it still happens and it does not seem to happen in 5/18 or 5/27 builds. So closing this.

Status: NEW → RESOLVED
Closed: 27 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.