Closed Bug 1707688 Opened 2 months ago Closed 2 months ago

HD content is no longer served by Amazon Prime for rented or purchased content due to HDCP check failure

Categories

(Core :: Audio/Video: Playback, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1705138

People

(Reporter: bryce, Assigned: bryce)

References

Details

In bug 1705138 we have reports of users no longer getting HD content when using Amazon Prime Video. I'm raising this bug to track the issue, though I am not able to reproduce the problem myself (e.g. I still get HD video served when testing with The Expanse).

Copying my comment from the other bug:

I suspect Amazon is serving lower resolution content to older versions of the CDM. If you navigate to about:support and find the media.gmp-widevinecdm.version preference value, recent versions of Fx will have 4.10.2209.1, while older ones will have a different version. It's those older versions I'd expect to see getting SD content.

If you have 4.10.2209.1 and are still getting SD, then could you post which video you're having issue with? Could you also navigate to about:support and use on of the buttons provided to copy the information and then attach it to this bug?

I am able to confirm I have 4.10.2209.1. This issue goes back a couple weeks when most (not all) Amazon owned movies began being forced to SD. There was no longer a HD indicator in the lower right and when clicking on the upper right gear it says "HD not available." Then clicking on "Why?" is states there is a HDCP issue at some level.

All my hardware and software are current. All are HDCP supported. This is specific to Firefox as it doesn't not occur on Edge. I originally posted on reddit and several other users have stated the issue happens for them too. I will post from the about:support but I apologize if this is more than needed. Specific movies: Avatar, Jack Reacher 4k, and many others. All of which streamed in HD prior to this. I've since disconnected all cables and the external monitor and now function on my Windows 10 laptop alone. The problem remains. I can provide screenshots as needed.

media.gmp-manager.lastCheck 1619445575
media.gmp-widevinecdm.abi x86-msvc-x64
media.gmp-widevinecdm.lastUpdate 1619215532
media.gmp-widevinecdm.version 4.10.2209.1
media.gmp.storage.version.observed 1
media.hardware-video-decoding.failed false
media.hardwaremediakeys.enabled false

Correction: There was no longer a HD indicator in the lower left(In reply to JJ from comment #2)

I am able to confirm I have 4.10.2209.1. This issue goes back a couple weeks when most (not all) Amazon owned movies began being forced to SD. There was no longer a HD indicator in the lower left and when clicking on the upper right gear it says "HD not available." Then clicking on "Why?" is states there is a HDCP issue at some level.

All my hardware and software are current. All are HDCP supported. This is specific to Firefox as it doesn't not occur on Edge. I originally posted on reddit and several other users have stated the issue happens for them too. I will post from the about:support but I apologize if this is more than needed. Specific movies: Avatar, Jack Reacher 4k, and many others. All of which streamed in HD prior to this. I've since disconnected all cables and the external monitor and now function on my Windows 10 laptop alone. The problem remains. I can provide screenshots as needed.

media.gmp-manager.lastCheck 1619445575
media.gmp-widevinecdm.abi x86-msvc-x64
media.gmp-widevinecdm.lastUpdate 1619215532
media.gmp-widevinecdm.version 4.10.2209.1
media.gmp.storage.version.observed 1
media.hardware-video-decoding.failed false
media.hardwaremediakeys.enabled false

Thanks for the report! It sounds like the issue is specific to movies purchased (or rented) through Amazon, is that correct? Rather than content that is included with Amazon Prime video? I would makes sense those may have different licensing restrictions imposed upon them and that bug 1705138 affecting them specifically.

We should have a mitigation landing in nightly soon after which I'll verify if it fixes this issue, at which point I'll dupe this back against bug 1705138 (if it does fix it).

Priority: P2 → P1
Summary: HD content is no longer served by Amazon Prime → HD content is no longer served by Amazon Prime for rented or purchased content due to HDCP check failure

I tested with Bliss(2021) on Amazon Prime. The video will have HD for both Safari(14.1) and Chrome(90.0.4430.85), but not Firefox(88.0, 90.0a1). media.gmp-widevinecdm.version=4.10.2209.1 in both version of Firefox. OS is Big Sur 11.3.

When checking HD Video Unavailable Why? from the upper right gear icon, following message pop up:

HD Video Unavailable Why?

Your video will play in Standard Definition because your computer hardware, HDMI cables, and display must all meet content protection (HDCP) requirements for HD video. For more information, go to our help section.

(In reply to Bryce Seager van Dyk (:bryce) from comment #4)

Thanks for the report! It sounds like the issue is specific to movies purchased (or rented) through Amazon, is that correct? Rather than content that is included with Amazon Prime video? I would makes sense those may have different licensing restrictions imposed upon them and that bug 1705138 affecting them specifically.

We should have a mitigation landing in nightly soon after which I'll verify if it fixes this issue, at which point I'll dupe this back against bug 1705138 (if it does fix it).

I just played around with several movies and TV shows. All the TV series were streaming in HD with the HD indicator visible. All movies I tried, owned or included in Prime, had the "HD not available" issue.

I will download Nightly and start migrating there.

Thanks for the further confirmations! I would be useful to confirm that the fix works in nightly once it's landed (it's not in yet). If the fix is verified we will also move to roll it into beta and release, so don't feel you have to migrate to nightly (a temporary profile is sufficient to test in nightly).

Okay, thanks. I will hold off for now.

Also confirming this issue. I have widevine CDM version 4.10.2209.1 -- Affects streamed movies as well as purchased, with the "HD Video Unavailable" warning message. I tested the same movies in Chrome and they have HD functionality.

Also the same "HD not available" on live streaming of MLB.tv games (paid subscription on Prime.)

Another place this can be seen -- free movies on IMDB TV. https://www.imdb.com/tv/watch/tt1374989. Leaving it here if it's helpful for testing.

To clarify some on my end, things like Amazon Prime's "Invincible" series that don't require HDCP for HD content will in fact play in HD.
But then movies like Once Bitten require HDCP and the HD symbol is grayed out and then becomes hidden.

I am on Nightly and all plugins up to date.

Thanks for the further information. A mitigation for this is in the most recent nightly and is working in my testing. If anyone else could verify the fix, that would be helpful.

The fix will also be taken into other versions of Firefox (first beta, then release and ESR).

Just tried it on Nightly. Not sure if I needed to make changes prior to testing it but I tried a movie (The Place Beyond the Pines) and it looked like for a split second it loaded with the HD indicator in the bottom left but then went to "HD not available." I'll try a few more now.

Okay. I'm clearly a novice at this. Just noticed the update for Nightly and after downloading, and a browser restart, that same movies is now streaming as it should be. HD indicator visible and no issues. Connected to external monitor as well.

And I can confirm the movies I referenced earlier (Avatar and Jack Reacher 4k) are streaming in HD now on Nightly. MLB.tv as well.

Thanks for checking that and confirming.

For anyone else who wants to make sure they're on the latest version, you can check if you're on the latest nightly by navigating to the About Nightly dialog from the menu bar (if you have it enabled), or the hamburger menu (the 3 lines in the upper right of the browser), Help -> About Nightly. That should show the build date (you'll need 2021-04-27 or newer), and give you an option to update if a more recent build is available.


It would still be useful to hear if this is fixing other folks issues. However, I think we have enough info to be confident this is bug 1705138. Thank you all for providing information to help track this down, and doing so on this bug. I know we've ended up round tripping back to the other bug, but even so it was useful to isolate this case for investigation, so appreciate folks following up over here.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1705138

Thank you for the help on this.

(In reply to LE from comment #11)

Another place this can be seen -- free movies on IMDB TV. https://www.imdb.com/tv/watch/tt1374989. Leaving it here if it's helpful for testing.

Unfortunately only available in the US at the moment.

See Also: → 1708363
You need to log in before you can comment on or make changes to this bug.