Closed Bug 1707970 Opened 2 months ago Closed 12 days ago

Can't rely on "browsing-context-discarded" for uninstalling SHistoryListeners

Categories

(Firefox :: Session Restore, defect, P2)

defect

Tracking

()

RESOLVED WONTFIX
Fission Milestone M7a
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- wontfix
firefox90 --- wontfix
firefox91 --- fix-optional

People

(Reporter: kashav, Assigned: kashav)

References

Details

In bug 1700963, I made it so we listen for "browsing-context-discarded" messages to detect that we can uninstall the context's associated SHistoryListener.

But it appears that the embedder element is always cleared before we fire "browsing-context-discarded", so we're not actually uninstalling listeners using this codepath. We might need to add a "browsing-context-will-clear-embedder" or something to know that the embedder element is being cleared, and use that instead.

(In reply to :kashav from comment #0)

We might need to add a "browsing-context-will-clear-embedder" or something to know that the embedder element is being cleared, and use that instead.

This doesn't work because we still end up clearing the embedder before SessionStore receives the notification.

Fission Milestone: --- → M7a
Depends on: 1706445
Assignee: nobody → kmadan
Severity: -- → S3
Status: NEW → ASSIGNED
Priority: -- → P2

That's a P2/S3 and we are in our last week of betas, so I am marking this bug as wontfix for 89.

Is there a user-facing impact here, that we need to track for 90?

Flags: needinfo?(kmadan)

No, there really shouldn't be any impact at all, since we're still removing listeners. I think calling it a regression was a little misleading.

Flags: needinfo?(kmadan)
No longer regressed by: 1700963
See Also: → 1700963

Bug 1706445 makes it so we unregister these listeners more reliably, so this shouldn't be a problem anymore. If this does become a problem, we might be to just unregister the listener after destroying the context's session history object.

Status: ASSIGNED → RESOLVED
Closed: 12 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.