<TABLE> element ignores style

VERIFIED DUPLICATE of bug 1044

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 1044
19 years ago
19 years ago

People

(Reporter: jwb, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Styles applied to the TABLE element are ignored, while styles applied to TR or
TD are treated correctly.  Consider these three test cases:

Case 1: Text is displayed normal size (wrong)

<HTML>
	<HEAD>
		<STYLE type="text/css">
			TABLE { font-size: xx-small }
		</STYLE>
	<HEAD>
	<BODY>
		<TABLE>
			<TR>
				<TD>Hello, Mozilla!</TD>
			</TR>
		</TABLE>
	</BODY>
</HTML>

Case 2: Text is displayed normal size (wrong)

<HTML>
	<BODY>
		<TABLE style="font-size: xx-small">
			<TR>
				<TD>Hello, Mozilla!</TD>
			</TR>
		</TABLE>
	</BODY>
</HTML>

Case 3: Text is displayed xx-small (right)

<HTML>
	<HEAD>
		<STYLE type="text/css">
			TR { font-size: xx-small }
		</STYLE>
	<HEAD>
	<BODY>
		<TABLE>
			<TR>
				<TD>Hello, Mozilla!</TD>
			</TR>
		</TABLE>
	</BODY>
</HTML>

Case 4: Text is displayed xx-small (right)

<HTML>
	<HEAD>
		<STYLE type="text/css">
			TD { font-size: xx-small }
		</STYLE>
	<HEAD>
	<BODY>
		<TABLE>
			<TR>
				<TD>Hello, Mozilla!</TD>
			</TR>
		</TABLE>
	</BODY>
</HTML>

Okay you get the idea.  I couldn't find this exact bug report, but this may be
related to Bug 1004 or Bug 3992 and probably others.

Mozilla M10 on Linux 2.2.
I think you meant bug 1044, not bug 1004.
(Assignee)

Comment 2

19 years ago
Reassigning peterl's bugs to myself
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
It is indeed a duplicate of #1044. I left some comments on #1044 pointing to the
test cases provided here.


*** This bug has been marked as a duplicate of 1044 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Verified dup of #1044
You need to log in before you can comment on or make changes to this bug.